summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-28 18:22:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-28 18:23:23 +0100
commit8e15f861399333ac8346458eba34ab3d94c69a27 (patch)
treec51cb01f5c9ad2f16fb68bf8d5ca99c32c6b0f32 /gnu
parentb8d13e2c0ee082b16f43930385cc34ce09ae4ef3 (diff)
downloadguix-8e15f861399333ac8346458eba34ab3d94c69a27.tar.gz
gnu: Add r-a4reporting.
* gnu/packages/bioconductor.scm (r-a4reporting): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f7191d2d4e..bdf8938488 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3032,3 +3032,26 @@ Affymetrix arrays.")
      "This is a package for the automated analysis of Affymetrix arrays.  It
 is used for preprocessing the arrays.")
     (license license:gpl3)))
+
+(define-public r-a4reporting
+  (package
+    (name "r-a4reporting")
+    (version "1.30.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "a4Reporting" version))
+       (sha256
+        (base32
+         "124774z3bfdjgxx2ad40795h92aam21yfx0rw0n01nk2wf6k7xc4"))))
+    (properties `((upstream-name . "a4Reporting")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annaffy" ,r-annaffy)
+       ("r-xtable" ,r-xtable)))
+    (home-page "https://bioconductor.org/packages/a4Reporting/")
+    (synopsis "Automated Affymetrix array analysis reporting package")
+    (description
+     "This is a package for the automated analysis of Affymetrix arrays.  It
+provides reporting features.")
+    (license license:gpl3)))