summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:42 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:32 +0200
commit9030b10b7668b167e73ed54db06f65f998851260 (patch)
tree5b3b7df1c0da7304aa572f837b0ccf48d3202440 /gnu
parent71ba1bc0c356d265891b8a7a2fad899c34995e44 (diff)
downloadguix-9030b10b7668b167e73ed54db06f65f998851260.tar.gz
gnu: Add trytond-sale-promotion.
* gnu/packages/tryton.scm (trytond-sale-promotion): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4735891f6c..0dddbb935b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3339,6 +3339,33 @@ price list on sale.  A price list can be set per party or as default.")
 customer's names and codes for products or variants.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-promotion
+  (package
+    (name "trytond-sale-promotion")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_promotion" version))
+       (sha256
+        (base32 "1bvk14sjlqrlg2wakihrcbz8vl40hr6isbc3ijdsv5g1khl3j74i"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_promotion"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-simpleeval" ,python-simpleeval)
+       ("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-product-price-list" ,trytond-product-price-list)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-sale-price-list" ,trytond-sale-price-list)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-promotion")
+    (synopsis "Tryton module for sale promotion")
+    (description "The @emph{Sale Promotion} module allows to apply promotions
+on sale based on criteria.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")