summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-07-25 20:48:24 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-07-25 21:27:25 +0200
commit930c52ae66eff9fb040877c315e029fc1a81e1fa (patch)
treec09372a6706de859453c58335bb3561f9759f414 /gnu
parentac629e625cb0a07cfef82d23a9342bba3f1f8029 (diff)
downloadguix-930c52ae66eff9fb040877c315e029fc1a81e1fa.tar.gz
gnu: Add perl-mail-dkim.
* gnu/packages/mail.scm (perl-mail-dkim): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f783271d18..3740e73d9f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1924,6 +1924,38 @@ is not fully compliant with the RFC but it tries to implement most styles of
 Authentication-Results header seen in the wild.")
     (license perl-license)))
 
+(define-public perl-mail-dkim
+  (package
+    (name "perl-mail-dkim")
+    (version "0.55")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                     "mirror://cpan/authors/id/M/MB/MBRADSHAW/Mail-DKIM-"
+                     version
+                     ".tar.gz"))
+              (sha256
+               (base32
+                "18nsh1ff6fkns4xk3y2ixmzmadgggydj11qkzj6nlnq2hzqxsafz"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-crypt-openssl-rsa" ,perl-crypt-openssl-rsa)
+       ("perl-mail-authenticationresults" ,perl-mail-authenticationresults)
+       ("perl-mailtools" ,perl-mailtools)
+       ("perl-net-dns" ,perl-net-dns)))
+    (native-inputs
+     `(("perl-net-dns-resolver-mock" ,perl-net-dns-resolver-mock)
+       ("perl-test-requiresinternet" ,perl-test-requiresinternet)
+       ("perl-yaml-libyaml" ,perl-yaml-libyaml)))
+    (home-page "https://metacpan.org/release/Mail-DKIM")
+    (synopsis "Signs/verifies Internet mail with DKIM/DomainKey signatures")
+    (description "Mail::DKIM is a Perl module that implements the new Domain
+Keys Identified Mail (DKIM) standard, and the older Yahoo! DomainKeys standard,
+both of which sign and verify emails using digital signatures and DNS records.
+Mail-DKIM can be used by any Perl program that wants to provide support for
+DKIM and/or DomainKeys.")
+    (license gpl3+)))
+
 (define-public mb2md
   (package
     (name "mb2md")