summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-08 21:47:54 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:48 -0500
commita54dda095f5568545f1de0c53c01e4d39ae42f9b (patch)
tree56a52ebec434192649d414fff35d36d2b314e11d /gnu
parent81b228ed14f50ff1d441d14c24520b226fbbd351 (diff)
downloadguix-a54dda095f5568545f1de0c53c01e4d39ae42f9b.tar.gz
gnu: ghc-stylish-haskell: Fix Cabal dependency constraints.
* gnu/packages/haskell-xyz.scm (ghc-stylish-haskell): Add a phase that
updates the Cabal file to allow for newer versions of
'haskell-src-exts'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f352f6b187..052162b66d 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10367,6 +10367,15 @@ occurrences of a substring (the first in case of overlaps) with another.")
           (base32
             "1ls11fdx6snvfx8yykpidz142zzxwi5bazl49hgfqlwx50rqcp7w"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "stylish-haskell.cabal"
+               (("haskell-src-exts >= 1\\.18   && < 1\\.21,")
+                "haskell-src-exts >= 1.18   && < 1.22,"))
+             #t)))))
     (inputs
       `(("ghc-aeson" ,ghc-aeson)
         ("ghc-file-embed" ,ghc-file-embed)