summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-27 20:34:33 +0200
committerMarius Bakke <marius@gnu.org>2022-06-27 23:48:00 +0200
commita83c462752649b058bef00bd3207451048f7d75e (patch)
treeef34a379c09d584742504d0204936d6e2dc7a7cb /gnu
parent6ee0f40e8344750c16de4885dd2e25f2e37e5163 (diff)
downloadguix-a83c462752649b058bef00bd3207451048f7d75e.tar.gz
gnu: python-libxml2: Fix build failure.
This is a follow-up to commit 7dfa2ff7804b4d4ffb4c256c5aaea92b2487b369.

* gnu/packages/xml.scm (python-libxml2)[arguments]: Provide correct directory
for libxml2 headers.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5ce2b140a7..9435e21d92 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -316,12 +316,9 @@ formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
                                                   "cross-libc" "libc")))
                   (libxml2 (assoc-ref inputs "libxml2")))
               (substitute* "setup.py"
-                ;; For 'libxml2/libxml/tree.h'.
-                (("ROOT = r'/usr'")
-                 (format #f "ROOT = r'~a'" libxml2))
-                ;; For 'iconv.h'.
+                ;; For libxml2 headers.
                 (("/opt/include")
-                 (string-append glibc "/include")))))))))
+                 (string-append libxml2 "/include")))))))))
     (inputs `(("libxml2" ,libxml2)))
     (synopsis "Python bindings for the libxml2 library")))