summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-08 00:30:08 +0100
committerMarius Bakke <marius@gnu.org>2020-12-08 00:45:56 +0100
commitadf0edadef9a60766f5786ab789d26a8248ab4d4 (patch)
tree2cd943441992ab242b9cc2c96176f4135f7448ae /gnu
parent627b70e3ac8aade9744a998c28570fbb52b986a7 (diff)
downloadguix-adf0edadef9a60766f5786ab789d26a8248ab4d4.tar.gz
gnu: qoauth: Minor cosmetic improvements.
* gnu/packages/web.scm (qoauth)[arguments]: Add #:tests?.  Don't delete
'check' phase.  Override 'configure' instead of adding new phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5c52a32927..ff40743832 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1063,7 +1063,8 @@ instances, while JSON's objects will be mapped to @code{QVariantMap}.")
      `(("qca" ,qca)
        ("qtbase" ,qtbase)))
     (arguments
-     '(#:phases
+     '(#:tests? #f                      ;FIXME: some tests are failing
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-code
            (lambda _
@@ -1079,11 +1080,9 @@ instances, while JSON's objects will be mapped to @code{QVariantMap}.")
                (("\\$\\$\\[QMAKE_MKSPECS\\]")
                 (string-append (assoc-ref outputs "out") "/lib/qt5/mkspecs")))
              #t))
-         (delete 'configure) ; no configure script
-         (delete 'check) ; no test target
-         (add-before 'build 'qmake
-           (lambda _
-             (let ((qca (assoc-ref %build-inputs "qca")))
+         (replace 'configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((qca (assoc-ref inputs "qca")))
                (invoke
                 "qmake"
                 (string-append "PREFIX=" (assoc-ref %outputs "out"))