summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-29 02:23:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-29 04:23:02 +0100
commitbb7c071b94ea88fdd2bda5ec78bbc08290d56b7b (patch)
tree40dad3d11b2ec9b336bd22a8313a37521f8c5288 /gnu
parent586d30caa2fb6372ab991f4284e92b19ebf15878 (diff)
downloadguix-bb7c071b94ea88fdd2bda5ec78bbc08290d56b7b.tar.gz
gnu: red-eclipse: Don't use unstable tarball.
* gnu/packages/games.scm (red-eclipse)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index aaa8c68f9c..01270fc5f4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2941,16 +2941,17 @@ http://lavachat.symlynx.com/unix/")
                    release
                    (string-append release "-"
                                   (number->string revision))))
-      (source (origin
-                (method url-fetch)
-                (uri (string-append "https://github.com/red-eclipse/base"
-                                    "/archive/v" release ".tar.gz"))
-                (file-name (string-append name "-" version ".tar.gz"))
-                (sha256
-                 (base32
-                  "1vs9k6f5fgsiy1n72imlqm8khjwm8cryc08zwd4gr7yxlxv45bs0"))
-                (patches
-                 (search-patches "red-eclipse-remove-gamma-name-hack.patch"))))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/red-eclipse/base.git")
+               (commit (string-append "v" release))))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0qy9kmq21wc4bdhwifasxc5dv1y5c53sn7dfmyc5y3zyz8wjyij4"))
+         (patches
+          (search-patches "red-eclipse-remove-gamma-name-hack.patch"))))
       (build-system gnu-build-system)
       (arguments
        `(#:tests? #f            ; no check target