summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-09-22 10:46:51 -0400
committerEfraim Flashner <efraim@flashner.co.il>2020-09-22 22:39:39 +0300
commitbd1bce0896150d7351d0c5553d197b0d628d8471 (patch)
treeb83e9b50949a6ebadcd39aff9b638bd46fd82abb /gnu
parentd3456739c5afd210cdc47b8c147adc277b84bfa8 (diff)
downloadguix-bd1bce0896150d7351d0c5553d197b0d628d8471.tar.gz
gnu: python-mpmath: Update to 1.1.0.
* gnu/packages/python-xyz.scm (python-mpmath): Update to 1.1.0.
[source]: Download from pypi.
[native-inputs]: Add pytest.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0e9809ebfe..9cf226299d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7525,15 +7525,17 @@ and statistical routines from scipy and statsmodels.")
 (define-public python-mpmath
   (package
   (name "python-mpmath")
-  (version "0.19")
+  (version "1.1.0")
   (source (origin
             (method url-fetch)
-            (uri (string-append "http://mpmath.org/files/mpmath-"
-                                version ".tar.gz"))
+            (uri (pypi-uri "mpmath" version))
+            (file-name (git-file-name name version))
             (sha256
              (base32
-              "08ijsr4ifrqv3cjc26mkw0dbvyygsa99in376hr4b96ddm1gdpb8"))))
+              "1xlrcja213jpfhw25q1jl5pl10w1a2cc68x1c4mkicxsbzhan5zw"))))
   (build-system python-build-system)
+  (native-inputs
+   `(("python-pytest" ,python-pytest)))
   (arguments
    '(#:phases
      (modify-phases %standard-phases