summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-30 15:47:31 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-04-30 18:01:03 +0200
commitc026db3f469d79e92155e7cb883830ccafc4206d (patch)
tree1f62681298e305ad873dc9a286e1bb8ded3550fa /gnu
parent39e88fa2c8790317c5f857f4c5f6f3fdc1697f20 (diff)
downloadguix-c026db3f469d79e92155e7cb883830ccafc4206d.tar.gz
gnu: ocaml: Update to 4.14.
* gnu/packages/ocaml.scm (ocaml-4.14): New variable.
(ocaml-4.13): Remove variable.
(ocaml-down): Update to 0.1.0.
(js-of-ocaml)[arguments]: Disable tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 71328b2a90..97c856869e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -182,10 +182,10 @@ OCaml and can effectively bootstrap OCaml 4.07.
 This package produces a native @command{ocamlc} and a bytecode @command{ocamllex}.")
       (license license:expat))))
 
-(define-public ocaml-4.13
+(define-public ocaml-4.14
   (package
     (name "ocaml")
-    (version "4.13.1")
+    (version "4.14.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -194,7 +194,7 @@ This package produces a native @command{ocamlc} and a bytecode @command{ocamllex
                     "/ocaml-" version ".tar.xz"))
               (sha256
                (base32
-                "1s7xwqidpjwfhnpfma4nb93gxfr7g9jfn03s1j03iyavmpgph7ck"))))
+                "0axcc7c23pf4qinz4vxgkba6pwziwbp9i2ydwzar7x9zlp6diarn"))))
     (build-system gnu-build-system)
     (native-search-paths
      (list (search-path-specification
@@ -244,7 +244,7 @@ functional, imperative and object-oriented styles of programming.")
 
 (define-public ocaml-4.09
   (package
-    (inherit ocaml-4.13)
+    (inherit ocaml-4.14)
     (version "4.09.0")
     (source (origin
               (method url-fetch)
@@ -460,7 +460,7 @@ depend: $(STDLIB_MLIS) $(STDLIB_DEPS)"))
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)))))
 
-(define-public ocaml ocaml-4.13)
+(define-public ocaml ocaml-4.14)
 
 (define-public ocamlbuild
   (package
@@ -694,7 +694,7 @@ repository-wide uninstallability checks.")
 (define-public ocaml-down
   (package
     (name "ocaml-down")
-    (version "0.0.3")
+    (version "0.1.0")
     (source
       (origin
         (method url-fetch)
@@ -702,7 +702,7 @@ repository-wide uninstallability checks.")
                             version ".tbz"))
         (sha256
          (base32
-          "1nz2f5j17frgr2vrslcz9klmi6w9sm2vqwwwpi33ngcm3rgmsrlg"))))
+          "1q467y6qz96ndiybpmggdcnrcip49kxw2i93pb54j1xjzkv1vnl1"))))
     (build-system ocaml-build-system)
     (arguments
      `(#:tests? #f ;no tests
@@ -8143,7 +8143,9 @@ libraries.")
        (sha256
         (base32 "0iyhl9z57j53j2jvyqcwmxhbvy23l6g80aa0abmlgwam14yskspf"))))
     (build-system dune-build-system)
-    (arguments `(#:test-target "."))
+    (arguments
+     `(#:tests? #f ;tests assume ocaml 4.13
+       #:test-target "."))
     (propagated-inputs
      (list ocaml-ppxlib
            ocaml-uchar