summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-10 23:19:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-13 00:21:47 +0200
commitc341b2addd29de5a04938987d55f319cfad81e96 (patch)
treecfffaebde18a0f2172ea2a7353ccfa10b6d99f2d /gnu
parentf9e5313cde19f978ca4379b41f3cb632e7395390 (diff)
downloadguix-c341b2addd29de5a04938987d55f319cfad81e96.tar.gz
gnu: fsarchiver: Move to (gnu packages file-systems).
* gnu/packages/disk.scm (fsarchiver): Move this variable…
* gnu/packages/file-systems.scm (fsarchiver): …here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/disk.scm36
-rw-r--r--gnu/packages/file-systems.scm38
2 files changed, 38 insertions, 36 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 15f08773f8..5c82ccd577 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -87,42 +87,6 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages))
 
-(define-public fsarchiver
-  (package
-    (name "fsarchiver")
-    (version "0.8.5")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://github.com/fdupoux/fsarchiver.git")
-         (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1rvwq5v3rl14bqxjm1ibfapyicf0sa44nw7451v10kx39lp56ylp"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("bzip2" ,bzip2)
-       ("e2fsprogs" ,e2fsprogs)
-       ("libgcrypt" ,libgcrypt)
-       ("lz4" ,lz4)
-       ("lzo" ,lzo)
-       ("util-linux" ,util-linux "lib")
-       ("xz" ,xz)
-       ("zlib" ,zlib)
-       ("zstd:lib" ,zstd "lib")))
-    (synopsis "Filesystem Backup/Deployment Tool")
-    (description "FSArchiver allows you to save the contents of a file-system to
-a compressed archive file.  The file-system can be restored on a partition which
-has a different size and it can be restored on a different file-system.")
-    (home-page "http://www.fsarchiver.org/")
-    (license license:gpl2)))
-
 (define-public udevil
   (package
     (name "udevil")
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 1ecc416740..8ac5447466 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -44,6 +45,7 @@
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnupg)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages nfs)
@@ -57,6 +59,42 @@
   #:use-module (gnu packages valgrind)
   #:use-module (gnu packages xml))
 
+(define-public fsarchiver
+  (package
+    (name "fsarchiver")
+    (version "0.8.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/fdupoux/fsarchiver.git")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1rvwq5v3rl14bqxjm1ibfapyicf0sa44nw7451v10kx39lp56ylp"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("bzip2" ,bzip2)
+       ("e2fsprogs" ,e2fsprogs)
+       ("libgcrypt" ,libgcrypt)
+       ("lz4" ,lz4)
+       ("lzo" ,lzo)
+       ("util-linux" ,util-linux "lib")
+       ("xz" ,xz)
+       ("zlib" ,zlib)
+       ("zstd:lib" ,zstd "lib")))
+    (synopsis "Filesystem Backup/Deployment Tool")
+    (description "FSArchiver allows you to save the contents of a file-system to
+a compressed archive file.  The file-system can be restored on a partition which
+has a different size and it can be restored on a different file-system.")
+    (home-page "http://www.fsarchiver.org/")
+    (license license:gpl2)))
+
 (define-public gphotofs
   (package
     (name "gphotofs")