summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-26 23:12:21 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-26 23:12:21 +0200
commitd85a7e8b4163dabfc4428fbc7093573edf14b027 (patch)
tree8c856848463c91aa83b84ae0aee85119503ba14a /gnu
parentd726b954baaeff876ce9728e00920fa45f529f9a (diff)
downloadguix-d85a7e8b4163dabfc4428fbc7093573edf14b027.tar.gz
gnu: nghttp2: Remove graft.
* gnu/packages/web.scm (nghttp2): Update to 1.41.0. Remove replacement.
  (nghttp2-1.41): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6907e133e6..ef81ae1a38 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7202,8 +7202,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
 (define-public nghttp2
   (package
     (name "nghttp2")
-    (version "1.40.0")
-    (replacement nghttp2-1.41)
+    (version "1.41.0")
     (source
      (origin
        (method url-fetch)
@@ -7212,7 +7211,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
                            "nghttp2-" version ".tar.xz"))
        (sha256
         (base32
-         "0wwhwv7cvi1vxpdjwvg0kpa4jzhszclpnwrwfcw728zz53a47z09"))))
+         "1hk77vngjmvvzb5y1gi1aqwf6qywrc7yak08zvzb7x81qs6mphmb"))))
     (build-system gnu-build-system)
     (outputs (list "out"
                    "lib"))              ; only libnghttp2
@@ -7286,20 +7285,6 @@ compressed JSON header blocks.
 @end itemize\n")
     (license license:expat)))
 
-(define-public nghttp2-1.41                       ;fixes CVE-2020-11080
-  (package
-    (inherit nghttp2)
-    (version "1.41.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/nghttp2/nghttp2/"
-                           "releases/download/v" version "/"
-                           "nghttp2-" version ".tar.xz"))
-       (sha256
-        (base32
-         "1hk77vngjmvvzb5y1gi1aqwf6qywrc7yak08zvzb7x81qs6mphmb"))))))
-
 (define-public hpcguix-web
   (let ((commit "9de63562b06b4aef3a3afe5ecb18d3c91e57ee74")
         (revision "5"))