summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-15 13:21:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-15 13:21:42 +0300
commitdda6b8b99f69ab253f11da166ffc4d81869d6278 (patch)
tree345305a9615c294b87fe124d49201cbea53ff51e /gnu
parent5254e375422750c8588b44eec07a6eb62e740abf (diff)
downloadguix-dda6b8b99f69ab253f11da166ffc4d81869d6278.tar.gz
gnu: python-trio: Honor #:tests? flag.
* gnu/packages/python-xyz.scm (python-trio)[arguments]: Honor #:tests?
flag.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 62fffda38a..ff5b0f00e4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22615,26 +22615,27 @@ project.")
              (setenv "HOME" "/tmp")
              #t))
          (replace 'check
-           (lambda _
-             (invoke "pytest" "-vv" "-k"
-                     (string-append
-                     ;; This test times out.
-                     "not test_ki_protection_works"
-                     ;; Assertion errors.
-                     " and not test_guest_mode_ki"
-                     " and not test_run_in_trio_thread_ki"
-                     " and not test_simple_cancel_scope_usage_doesnt_create_cyclic_garbage"
-                     " and not test_nursery_cancel_doesnt_create_cyclic_garbage"
-                     " and not test_locals_destroyed_promptly_on_cancel"
-                     ;; These try to raise KeyboardInterrupt which does not work
-                     ;; in the build environment.
-                     " and not test_ki_self"
-                     " and not test_ki_wakes_us_up"
-                     ;; Failure in name resolution.
-                     " and not test_getnameinfo"
-                     " and not test_SocketType_resolve"
-                     ;; OSError: protocol not found.
-                     " and not test_getprotobyname")))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-vv" "-k"
+                       (string-append
+                         ;; This test times out.
+                         "not test_ki_protection_works"
+                         ;; Assertion errors.
+                         " and not test_guest_mode_ki"
+                         " and not test_run_in_trio_thread_ki"
+                         " and not test_simple_cancel_scope_usage_doesnt_create_cyclic_garbage"
+                         " and not test_nursery_cancel_doesnt_create_cyclic_garbage"
+                         " and not test_locals_destroyed_promptly_on_cancel"
+                         ;; These try to raise KeyboardInterrupt which does not work
+                         ;; in the build environment.
+                         " and not test_ki_self"
+                         " and not test_ki_wakes_us_up"
+                         ;; Failure in name resolution.
+                         " and not test_getnameinfo"
+                         " and not test_SocketType_resolve"
+                         ;; OSError: protocol not found.
+                         " and not test_getprotobyname"))))))))
     (native-inputs
      `(("python-astor" ,python-astor)
        ("python-ipython" ,python-ipython)