summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 00:06:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:38 +0100
commite74e1ad61008bb2af275c2cb879327f9e72a6b19 (patch)
tree386497f8567355008c83d05dc12624ea4622da94 /gnu
parent31b49f51c2fd361a659e1549bd1a0edc5f74b002 (diff)
downloadguix-e74e1ad61008bb2af275c2cb879327f9e72a6b19.tar.gz
gnu: ghc-aeson: Update to 1.2.4.0.
* gnu/packages/haskell-web.scm (ghc-aeson): Update to 1.2.4.0.
[inputs]: Add ghc-base-compat, ghc-tagged, ghc-th-abstraction,
ghc-time-locale-compat, ghc-uuid-types, ghc-integer-logarithms,
ghc-base-orphans, ghc-base16-bytestring, ghc-generic-deriving,
ghc-test-framework, ghc-test-framework-hunit, ghc-test-framework-quickcheck2,
ghc-quickcheck-instances, and ghc-hashable-time; remove ghc-mtl and ghc-syb.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-web.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 8aaa435705..f738b69234 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -726,7 +726,7 @@ Strict, Transitional and Frameset variants.")
 (define-public ghc-aeson
   (package
     (name "ghc-aeson")
-    (version "0.10.0.0")
+    (version "1.2.4.0")
     (source
      (origin
        (method url-fetch)
@@ -736,21 +736,33 @@ Strict, Transitional and Frameset variants.")
              ".tar.gz"))
        (sha256
         (base32
-         "19kp33rfivr4d3myyr8xn803wd7p8x5nc4wb3qvlgjwgyqjaxvrz"))))
+         "16zwpd07cmhs58wwsqbhxy3b58gqw8w5nr7nf6lwi4nvznjdn09l"))))
     (build-system haskell-build-system)
     (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
     (inputs
      `(("ghc-attoparsec" ,ghc-attoparsec)
+       ("ghc-base-compat" ,ghc-base-compat)
        ("ghc-dlist" ,ghc-dlist)
-       ("ghc-mtl" ,ghc-mtl)
+       ("ghc-hashable" ,ghc-hashable)
        ("ghc-scientific" ,ghc-scientific)
-       ("ghc-syb" ,ghc-syb)
+       ("ghc-tagged" ,ghc-tagged)
+       ("ghc-text" ,ghc-text)
+       ("ghc-th-abstraction" ,ghc-th-abstraction)
+       ("ghc-time-locale-compat" ,ghc-time-locale-compat)
        ("ghc-unordered-containers" ,ghc-unordered-containers)
+       ("ghc-uuid-types" ,ghc-uuid-types)
        ("ghc-vector" ,ghc-vector)
-       ("ghc-hashable" ,ghc-hashable)
-       ("ghc-text" ,ghc-text)
        ("ghc-hunit" ,ghc-hunit)
-       ("ghc-quickcheck" ,ghc-quickcheck)))
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-integer-logarithms" ,ghc-integer-logarithms)
+       ("ghc-base-orphans" ,ghc-base-orphans)
+       ("ghc-base16-bytestring" ,ghc-base16-bytestring)
+       ("ghc-generic-deriving" ,ghc-generic-deriving)
+       ("ghc-test-framework" ,ghc-test-framework)
+       ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+       ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+       ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+       ("ghc-hashable-time" ,ghc-hashable-time)))
     (home-page "https://github.com/bos/aeson")
     (synopsis "Fast JSON parsing and encoding")
     (description "This package provides a JSON parsing and encoding library