summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 21:50:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:12 +0300
commite77383e16fe4244a82b5e988e6edcfb52bf8965c (patch)
treee0e1fe80372ffc0f24ac23211fde47599908a046 /gnu
parent4892c1af84a83b9c966af1dc5ea085f8122cfa05 (diff)
downloadguix-e77383e16fe4244a82b5e988e6edcfb52bf8965c.tar.gz
gnu: go-github.com-smartystreets-assertions: Skip tests with gccgo.
* gnu/packages/check.scm (go-github.com-smartystreets-assertions): Don't
run the test suite when building with gccgo.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 2bb8128f34..26a49056a2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -676,7 +676,16 @@ test) much simpler.")
                (base32 "0flf3fb6fsw3bk1viva0fzrzw87djaj1mqvrx2gzg1ssn7xzfrzr"))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/smartystreets/assertions"))
+     (list
+       #:import-path "github.com/smartystreets/assertions"
+       #:phases
+       #~(modify-phases %standard-phases
+           (replace 'check
+             (lambda* (#:key inputs #:allow-other-keys #:rest args)
+               (unless
+                 ;; The tests fail when run with gccgo.
+                 (false-if-exception (search-input-file inputs "/bin/gccgo"))
+                 (apply (assoc-ref %standard-phases 'check) args)))))))
     (native-inputs
      (list go-github.com-smartystreets-gunit))
     (synopsis "Assertions for testing with Go")