summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-12-11 14:23:26 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-09 17:40:54 +0100
commite8b90b1d5d9d7fa30a3f3756b5ec2b26488066b0 (patch)
tree334fa76ba5283f2f971a5335f7ca483215a69d90 /gnu
parent6c343d0d0f6b8560e9eb594ce1d4f984753a35fb (diff)
downloadguix-e8b90b1d5d9d7fa30a3f3756b5ec2b26488066b0.tar.gz
gnu: Add minetest-wielded-light.
* gnu/packages/minetest.scm (minetest-wielded-light): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/minetest.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 0f017217de..0ee6690826 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -769,3 +769,25 @@ build your island in the sky.  Every 30 seconds you will receive a random
 block or item from the oneblock to expand the island!")
     (license license:gpl3+)
     (properties `((upstream-name . "NO11/oneblock")))))
+
+(define-public minetest-wielded-light
+  (package
+    (name "minetest-wielded-light")
+    (version "2022-06-24")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/minetest-mods/wielded_light")
+                    (commit "b5236562af9772dff8522fe2bda5b5f738e81b88")))
+              (sha256
+               (base32
+                "0m5rf8wkc9iq04xppjfva9d83qmhlnx8fibdbi2d3pkwwl6p2y5c"))
+              (file-name (git-file-name name version))))
+    (build-system minetest-mod-build-system)
+    (home-page (minetest-topic 19378))
+    (synopsis "Adds shining for wielded and dropped items")
+    (description
+     "With this Minetest extension, all bright nodes lighten the player
+environment if wielded.")
+    (license license:gpl3+)
+    (properties `((upstream-name . "bell07/wielded_light")))))