summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-26 00:06:39 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 19:39:25 +0100
commite9d3f3656bd8a16deb1f643c9ed9f5706a6f9eaf (patch)
tree70defd712f97d44e3a27721709beb2c7740ece3f /gnu
parent40239e23e8154ce3bfe1a98c5a2df1a0094789e4 (diff)
downloadguix-e9d3f3656bd8a16deb1f643c9ed9f5706a6f9eaf.tar.gz
gnu: Add ocaml-lacaml.
* gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
(ocaml-lacaml): ...this.  Use latest ocaml package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 990b33752a..56c56dd929 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6922,7 +6922,7 @@ language understood by ocamldoc.")
        ("fftwf" ,fftwf)))
     (native-inputs
      `(("ocaml-cppo" ,(package-with-ocaml4.07 ocaml-cppo))
-       ("ocaml-lacaml" ,ocaml4.07-lacaml)))
+       ("ocaml-lacaml" ,(package-with-ocaml4.07 ocaml-lacaml))))
     (home-page
      "https://github.com/Chris00/fftw-ocaml")
     (synopsis
@@ -6932,10 +6932,10 @@ language understood by ocamldoc.")
 library FFTW.")
     (license license:lgpl2.1))) ; with static linking exception.
 
-(define-public ocaml4.07-lacaml
+(define-public ocaml-lacaml
   (package
-    (name "ocaml4.07-lacaml")
-    (version "11.0.5")
+    (name "ocaml-lacaml")
+    (version "11.0.8")
     (source
      (origin
        (method git-fetch)
@@ -6945,18 +6945,15 @@ library FFTW.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "180yb79a3qgx067qcpm50q12hrimjygf06rgkzbish9d1zfm670c"))))
+         "115535kphchh2a434b48b408x9794j8zzrsdmacsgqdsrgy3rck4"))))
     (build-system dune-build-system)
     (arguments
-     `(#:tests? #f ; No test target.
-       #:ocaml ,ocaml-4.07
-       #:findlib ,ocaml4.07-findlib
-       #:dune ,ocaml4.07-dune))
+     `(#:tests? #f)) ; No test target.
     (native-inputs
      `(("openblas" ,openblas)
        ("lapack" ,lapack)
-       ("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
-       ("ocaml-stdio" ,(package-with-ocaml4.07 ocaml-stdio))))
+       ("ocaml-base" ,ocaml-base)
+       ("ocaml-stdio" ,ocaml-stdio)))
     (home-page "https://mmottl.github.io/lacaml/")
     (synopsis
      "OCaml-bindings to BLAS and LAPACK")