summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-10 14:03:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-10 14:03:15 +0100
commiteca528cca987ada1942721403794dff32121bfa6 (patch)
tree1e8c3ed38a57c2911fb8f30eb97cf1927532a00a /gnu
parente7db97db6353d631e9319360a17d9b26fc8d0bc0 (diff)
downloadguix-eca528cca987ada1942721403794dff32121bfa6.tar.gz
gnu: make-lure-package: Fix data and documentation location.
* gnu/packages/games.scm (make-lure-package)[arguments]: Make data and
documentation location dependent on localization.
[native-inputs]: Move bash...
[inputs]: here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5aa4ab7b01..e82c3c44b6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7751,7 +7751,7 @@ the World and demonstrating that he is even more evil than his brother Vlad.")
          (use-modules (guix build utils))
          (let* ((out (assoc-ref %outputs "out"))
                 (share (string-append out "/share"))
-                (data (string-append share "/lure/" ,language))
+                (data (string-append share "/" ,name "/" ,language))
                 (apps (string-append share "/applications"))
                 (bin (string-append out "/bin"))
                 (executable (string-append bin "/" ,name))
@@ -7759,7 +7759,7 @@ the World and demonstrating that he is even more evil than his brother Vlad.")
            (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
                                        "/bin/unzip")))
              (invoke unzip "-j" (assoc-ref %build-inputs "source")))
-           (let ((doc (string-append share "/doc/lure-" ,version)))
+           (let ((doc (string-append share "/doc/" ,name "-" ,version)))
              (for-each (lambda (f) (install-file f doc))
                        (find-files "." "\\.(txt|PDF|pdf)$")))
            (for-each (lambda (f) (install-file f data))
@@ -7794,10 +7794,10 @@ the World and demonstrating that he is even more evil than his brother Vlad.")
                        executable scummvm)))
            #t))))
     (native-inputs
-     `(("bash" ,bash)
-       ("unzip" ,unzip)))
+     `(("unzip" ,unzip)))
     (inputs
-     `(("scummvm" ,scummvm)))
+     `(("bash" ,bash)
+       ("scummvm" ,scummvm)))
     (home-page "https://www.scummvm.org")
     (synopsis "2D point and click fantasy adventure game")
     (description