summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-16 09:42:08 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:50 -0500
commiteef308d62a488fe56344ba8f7949217fb8cba427 (patch)
tree08a214eb6b779aa867bc7f965a34ac809c96f95e /gnu
parent3594b6699d3043029f85fda2ccd82da1ae17e61b (diff)
downloadguix-eef308d62a488fe56344ba8f7949217fb8cba427.tar.gz
gnu: elm-compiler: Fix Cabal dependency constraints.
This package used a patch to update the Cabal version constraints for
'language-glsl'.  This is now done in a phase for consistency with
other Haskell packages.

* gnu/packages/elm.scm (elm-compiler): Add a phase that updates the
Cabal file to allow for newer versions of 'ansi-terminal',
'containers', 'http-client', 'language-glsl', and 'network'.
[source]: Remove 'elm-compiler-relax-glsl-bound.patch'.
* gnu/packages/patches/elm-compiler-relax-glsl-bound.patch: Delete file.
* gnu/local.mk: Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/elm.scm18
-rw-r--r--gnu/packages/patches/elm-compiler-relax-glsl-bound.patch19
3 files changed, 17 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f7d37c4f81..d580ff72d0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -796,7 +796,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/elixir-path-length.patch			\
   %D%/packages/patches/elm-compiler-disable-reactor.patch	\
   %D%/packages/patches/elm-compiler-fix-map-key.patch		\
-  %D%/packages/patches/elm-compiler-relax-glsl-bound.patch	\
   %D%/packages/patches/emacs-dired-toggle-sudo-emacs-26.patch   \
   %D%/packages/patches/emacs-exec-path.patch			\
   %D%/packages/patches/emacs-fix-scheme-indent-function.patch	\
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 8b5ec36621..feaa9c8d5c 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -47,9 +47,25 @@
         (base32 "0s93z9vr0vp5w894ghc5s34nsq09sg1msf59zfiba87sid5vgjqy"))
        (patches
         (search-patches "elm-compiler-disable-reactor.patch"
-                        "elm-compiler-relax-glsl-bound.patch"
                         "elm-compiler-fix-map-key.patch"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'update-constraints
+           (lambda _
+             (substitute* "elm.cabal"
+               (("ansi-terminal >= 0\\.8 && < 0\\.9,")
+                "ansi-terminal >= 0.8 && < 0.10,")
+               (("containers >= 0\\.5\\.8\\.2 && < 0\\.6,")
+                "containers >= 0.5.8.2 && < 0.7,")
+               (("http-client >= 0\\.5 && < 0\\.6,")
+                "http-client >= 0.5 && < 0.7,")
+               (("language-glsl >= 0\\.0\\.2 && < 0\\.3,")
+                "language-glsl >= 0.0.2 && < 0.4,")
+               (("network >= 2\\.4 && < 2\\.7,")
+                "network >= 2.4 && < 2.9,"))
+             #t)))))
     (inputs
      `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
        ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
diff --git a/gnu/packages/patches/elm-compiler-relax-glsl-bound.patch b/gnu/packages/patches/elm-compiler-relax-glsl-bound.patch
deleted file mode 100644
index 3f8be810c2..0000000000
--- a/gnu/packages/patches/elm-compiler-relax-glsl-bound.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 4c649a5a270aba15cc6a3913c3ad51a293047f40
-Author: Rémi Lefèvre <rlefevre@gmail.com>
-Date:   Mon Sep 3 19:18:54 2018 +0200
-
-    update language-glsl maximum version
-
-diff --git a/elm.cabal b/elm.cabal
-index 48aa84f0..464fe9d5 100644
---- a/elm.cabal
-+++ b/elm.cabal
-@@ -246,7 +246,7 @@ Executable elm
-         http-client >= 0.5 && < 0.6,
-         http-client-tls >= 0.3 && < 0.4,
-         http-types >= 0.9 && < 1.0,
--        language-glsl >= 0.0.2 && < 0.3,
-+        language-glsl >= 0.0.2 && < 0.4,
-         logict,
-         mtl >= 2.2.1 && < 3,
-         network >= 2.4 && < 2.7,