summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-15 09:21:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-15 09:22:51 +0100
commitf529dfec74c2f5cbfe9cda65f9ee4b02fe12dbf9 (patch)
treed3ba6d4c044b6f0ff64bedc9c0217694d7974a22 /gnu
parent60a32a2d60e5ccb5a72a61212c045439929b4dc8 (diff)
downloadguix-f529dfec74c2f5cbfe9cda65f9ee4b02fe12dbf9.tar.gz
gnu: python-3.6: Disable failing test.
* gnu/packages/python.scm (python-3.6)[source]: Delete
Lib/test/test_socket.py.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 106c040bf8..d091157d8a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -357,7 +357,11 @@ data types.")
                   (for-each delete-file
                             '("Lib/ctypes/test/test_structures.py" ; fails on aarch64
                               "Lib/ctypes/test/test_win32.py" ; fails on aarch64
-                              "Lib/test/test_fcntl.py")) ; fails on aarch64
+                              "Lib/test/test_fcntl.py" ; fails on aarch64
+                              ;; This test fails on kernels older than 4.5.
+                              ;; It is skipped on these kernels in later
+                              ;; versions of Python.
+                              "Lib/test/test_socket.py"))
                   #t))))
     (arguments (substitute-keyword-arguments (package-arguments python-2)
                  ((#:tests? _) #t)))