summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-13 11:29:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-13 11:29:36 +0300
commitf90b26917a49a5e2f41b82b920d25666d73f49d4 (patch)
treeb5fde04fd5c41ea656b2a5702d700f97f484e311 /gnu
parent9ac2a4ee3424dd216b1b67056968e0585197952a (diff)
downloadguix-f90b26917a49a5e2f41b82b920d25666d73f49d4.tar.gz
gnu: dlib: Install shared library.
Reported by Hamzeh Nasajpour <h.nasajpour@pantherx.org>.

* gnu/packages/machine-learning.scm (dlib)[arguments]: Add
configure-flag to build shared library. Remove custom
'delete-static-library phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 163ebded07..1f4c2e23ea 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -773,7 +773,8 @@ than 8 bits, and at the end only some significant 8 bits are kept.")
                   #t))))
     (build-system cmake-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-asserts
            (lambda _
@@ -810,12 +811,7 @@ than 8 bits, and at the end only some significant 8 bits are kept.")
                (with-directory-excursion test-dir
                  (invoke "make" "-j" (number->string (parallel-job-count)))
                  (invoke "./dtest" "--runall"))
-               #t)))
-         (add-after 'install 'delete-static-library
-           (lambda* (#:key outputs #:allow-other-keys)
-             (delete-file (string-append (assoc-ref outputs "out")
-                                         "/lib/libdlib.a"))
-             #t)))))
+               #t))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ;; For tests.