summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 19:03:51 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:30 +0200
commitfd4a80a46c535e7911559fe0d03ad3855457927e (patch)
tree6037808296b586eafee29ada4d15a923f64d0556 /gnu
parent0402da848b60bfd4f1c66768122208739f9cfa6d (diff)
downloadguix-fd4a80a46c535e7911559fe0d03ad3855457927e.tar.gz
gnu: Add erlang-rebar3-proper.
* gnu/packages/erlang.scm (erlang-rebar3-proper): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/erlang.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 9255edebbe..b9c7424441 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -543,6 +543,23 @@ testing of stateful systems.")
 a git checkout.")
     (license license:expat)))
 
+(define-public erlang-rebar3-proper
+  (package
+    (name "erlang-rebar3-proper")
+    (version "0.12.1")
+    (source
+      (origin
+        (method hexpm-fetch)
+        (uri (hexpm-uri "rebar3_proper" version))
+        (sha256
+          (base32 "0j3a9byxbdrfinynq2xdz5mz7s4vpdlsmv7lln80lpqxswnafpfv"))))
+    (build-system rebar3-build-system)
+    (home-page "https://github.com/ferd/rebar3_proper")
+    (synopsis "Rebar3 PropEr plugin")
+    (description "This plugin allows running PropEr test suites from within
+rebar3.")
+    (license license:bsd-3)))
+
 (define-public erlang-rebar3-raw-deps
   (package
     (name "erlang-rebar3-raw-deps")