summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJane Baines <jmbaines8@gmail.com>2018-02-24 19:13:58 +0000
committerChristopher Baines <mail@cbaines.net>2018-02-24 19:40:27 +0000
commit0458ab53f6ab58c42f379b8e7d55d130df4232e3 (patch)
tree8bb4288d3b9c803e834e8668f83e40e767ea3df8 /gnu
parentf09cb93e3a2310f7726cb98fa5679c1a8483c39f (diff)
downloadguix-0458ab53f6ab58c42f379b8e7d55d130df4232e3.tar.gz
gnu: python-django: Update to 1.11.10.
* gnu/packages/django.scm (python-django)[version]: Update to version 1.11.10.
  [arguments]: Patch test helper to add python-pytz to the PYTHONPATH.
  [inputs]: Remove python-pytz.
  [propagated-inputs]: Add python-pytz.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 3864cc884b..0b447b5176 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -36,16 +36,19 @@
 (define-public python-django
   (package
     (name "python-django")
-    (version "1.10.8")
+    (version "1.11.10")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "Django" version))
               (sha256
                (base32
-                "1fwqqh2zbcy9dy0lnvk338s11llnnfz2k56bf84w0wv56ayq7vyl"))))
+                "1ndc7axr7cz8jwhr4mz16fvwd0jcd6i81q2wi9nl172s71kkaf12"))))
     (build-system python-build-system)
     (arguments
-     '(#:phases
+     '(#:modules ((srfi srfi-1)
+                  (guix build python-build-system)
+                  (guix build utils))
+       #:phases
        (modify-phases %standard-phases
          (add-before 'check 'set-tzdir
            (lambda* (#:key inputs #:allow-other-keys)
@@ -56,9 +59,19 @@
                                     "/share/zoneinfo"))
              #t))
          (replace 'check
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              (setenv "PYTHONPATH"
                      (string-append ".:" (getenv "PYTHONPATH")))
+             (substitute* "tests/admin_scripts/tests.py"
+               (("python_path = \\[")
+                (string-append "python_path = ['"
+                               (find (lambda (entry)
+                                       (string-prefix?
+                                        (assoc-ref inputs "python-pytz")
+                                        entry))
+                                     (string-split (getenv "PYTHONPATH")
+                                                   #\:))
+                               "', ")))
              (zero? (system* "python" "tests/runtests.py")))))))
     ;; TODO: Install extras/django_bash_completion.
     (native-inputs
@@ -75,10 +88,11 @@
        ("python-numpy" ,python-numpy)
        ("python-pillow" ,python-pillow)
        ("python-pyyaml" ,python-pyyaml)
-       ("python-pytz" ,python-pytz)
        ;; optional for tests: ("python-selenium" ,python-selenium)
        ("python-sqlparse" ,python-sqlparse)
        ("python-tblib" ,python-tblib)))
+    (propagated-inputs
+     `(("python-pytz" ,python-pytz)))
     (home-page "http://www.djangoproject.com/")
     (synopsis "High-level Python Web framework")
     (description