summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-04-13 10:41:57 -0400
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-04-13 12:08:17 -0400
commit0de9813905ebec00d1b1e8fbabe8dc024900180a (patch)
treeab6b82aff963700c0ebfae6b83e04a556b6b89ea /gnu
parent57c9c349b77ea9a949286222ee10a5da317f2806 (diff)
downloadguix-0de9813905ebec00d1b1e8fbabe8dc024900180a.tar.gz
gnu: geda-gaf: Make gsch2pcb work out-of-the-box.
* gnu/packages/engineering.scm (geda-gaf)[inputs]: Add m4 and pcb.
[arguments]: Add configure flags that point to PCB data files.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 9a36ffbb31..9a299d91c8 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 David Thompson <davet@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -45,6 +46,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages linux)               ;FIXME: for pcb
+  #:use-module (gnu packages m4)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -124,13 +126,22 @@ plans and designs.")
         'check 'set-home
         (lambda _
           (setenv "HOME" (getenv "TMPDIR")))
-        %standard-phases)))
+        %standard-phases
+        )
+       #:configure-flags
+       (let ((pcb (assoc-ref %build-inputs "pcb")))
+         (list (string-append "--with-pcb-datadir=" pcb "/share")
+               (string-append "--with-pcb-lib-path="
+                              pcb "/share/pcb/pcblib-newlib:"
+                              pcb "/share/pcb/newlib")))))
     (inputs
      `(("glib" ,glib)
        ("gtk" ,gtk+-2)
        ("guile" ,guile-2.0)
        ("desktop-file-utils" ,desktop-file-utils)
-       ("shared-mime-info" ,shared-mime-info)))
+       ("shared-mime-info" ,shared-mime-info)
+       ("m4" ,m4)
+       ("pcb" ,pcb)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("perl" ,perl))) ; for tests