summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-25 09:54:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-25 22:07:32 +0200
commit10a661c8c86d17b72669a71099bad101273d3e4d (patch)
tree4fc9da94874e25685a80e48417b33a901d31d798 /gnu
parent91bcc26b1c97d440c203ea9e258ca56a89377bc8 (diff)
downloadguix-10a661c8c86d17b72669a71099bad101273d3e4d.tar.gz
gnu: syslinux: Honor #:tests? flag.
* gnu/packages/bootloaders.scm (syslinux)[arguments]: Adjust custom
'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 57705cf596..89f051f337 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -537,12 +537,13 @@ The SUBDIR argument defaults to \"efi/Guix\", as it is also the case for
              (lambda _
                (invoke "chmod" "a+w" "utils/isohybrid.in")))
            (replace 'check
-             (lambda _
-               (setenv "CC" "gcc")
-               (substitute* "tests/unittest/include/unittest/unittest.h"
-                 ;; Don't look up headers under /usr.
-                 (("/usr/include/") ""))
-               (invoke "make" "unittest"))))))
+             (lambda* (#:key tests? #:allow-other-keys)
+               (when tests?
+                 (setenv "CC" "gcc")
+                 (substitute* "tests/unittest/include/unittest/unittest.h"
+                   ;; Don't look up headers under /usr.
+                   (("/usr/include/") ""))
+                 (invoke "make" "unittest")))))))
       (home-page "https://www.syslinux.org")
       (synopsis "Lightweight Linux bootloader")
       (description "Syslinux is a lightweight Linux bootloader.")