summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-09 13:25:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-10 01:03:56 -0400
commit13c73ccd902c55ef859cf2b8a5f96d93007892d8 (patch)
tree251f506cb025080f90e8fb71cdf0c96b7ec1264e /gnu
parentc9fb789fe9eaa5dc0694ef14fe36e5aa821a646c (diff)
downloadguix-13c73ccd902c55ef859cf2b8a5f96d93007892d8.tar.gz
gnu: Add emacs-robot-log.
* gnu/packages/emacs-xyz.scm (emacs-robot-log): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9dbed0d881..4762cc3485 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5764,6 +5764,30 @@ features such as syntax highlighting, comments, finding keywords, completing
 keywords and smart indentation.")
     (license license:gpl3+)))
 
+(define-public emacs-robot-log
+  (package
+    (name "emacs-robot-log")
+    (version "0.1.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~apteryx/emacs-robot-log")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0pv0kljx2n2n7ql6rfw1x63mbd1k2qwbq3zkw452lb8jmnp7dr3y"))))
+    (build-system emacs-build-system)
+    (native-inputs (list python-robotframework))
+    (arguments (list #:tests? #t))
+    (home-page "https://sr.ht/~apteryx/emacs-robot-log/")
+    (synopsis "Emacs major mode for viewing RobotFramework debug log files")
+    (description "@code{robot-log} is an Emacs major mode that allows more
+easily viewing and navigating RobotFramework debug log files.  It provides
+syntax highlighting and convenient shortcuts to move from one keyword to the
+next, or locate errors.")
+    (license license:gpl3+)))
+
 (define-public emacs-robots-txt-mode
   (package
     (name "emacs-robots-txt-mode")