summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-05-14 15:53:48 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-05-14 15:54:32 +0200
commit16ad755f94597cc47725a030ef1a65f94d4155c8 (patch)
tree658f4f1608af1dac34a265f34f271246aa693b31 /gnu
parente685ae63bb911fddaa671b618ee13ddae2bc4e71 (diff)
downloadguix-16ad755f94597cc47725a030ef1a65f94d4155c8.tar.gz
gnu: python-jupyter-core: Disable config migration.
* gnu/packages/python-xyz.scm (python-jupyter-core) [#:phases]: Add new
phase 'disable-migration, which disables migration of Guix-owned
configuration directories.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c57498c40..cf0eba3234 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7605,7 +7605,18 @@ without using the configuration machinery.")
                 "env = {'PATH': '', 'PYTHONPATH': os.environ['PYTHONPATH']}")
                (("env = \\{'PATH':  str\\(b\\)\\}")
                 "env = {'PATH': str(b), 'PYTHONPATH': os.environ['PYTHONPATH']}"))
-             #t)))))
+             #t))
+         ;; Migration is running whenever etc/jupyter exists, but the
+         ;; Guix-managed directory will never contain any migratable IPython
+         ;; config files and cannot be written to anyway, so just pretend we
+         ;; already did that.
+         (add-after 'install 'disable-migration
+           (lambda* (#:key outputs #:allow-other-keys)
+             (mkdir-p (string-append (assoc-ref outputs "out") "/etc/jupyter"))
+             (invoke "touch"
+               (string-append
+                 (assoc-ref outputs "out")
+                 "/etc/jupyter/migrated")))))))
     (propagated-inputs
      `(("python-traitlets" ,python-traitlets)))
     (native-inputs