summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 10:26:27 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:15 -0500
commit17482b26fb0fa676700ce302d91a51ecbcab04d9 (patch)
tree192f743f39b2ce2a67be313669bf923ec8c2de1d /gnu
parentbb148db899adb4828fd6baf091d13143b088c1e8 (diff)
downloadguix-17482b26fb0fa676700ce302d91a51ecbcab04d9.tar.gz
gnu: ghc-fgl: Update to 5.7.0.1.
* gnu/packages/haskell-xyz.scm (ghc-fgl): Update to 5.7.0.1.
[arguments]: Change the phase that updates the Cabal file to allow for
newer versions of 'hspec' and 'QuickCheck'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3e01f349dd..3d06fc316e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3395,7 +3395,7 @@ consuming feeds in both RSS (Really Simple Syndication) and Atom format.")
 (define-public ghc-fgl
   (package
     (name "ghc-fgl")
-    (version "5.6.0.0")
+    (version "5.7.0.1")
     (outputs '("out" "doc"))
     (source
      (origin
@@ -3406,7 +3406,7 @@ consuming feeds in both RSS (Really Simple Syndication) and Atom format.")
              ".tar.gz"))
        (sha256
         (base32
-         "1i6cp4b3w7sjk7y1dq3fh6bci2sm5h3lnbbaw9ln19nwncg2wwll"))))
+         "04793yh778ck3kz1z2svnfdwwls2kisbnky4lzvf4zjfgpv7mkpz"))))
     (build-system haskell-build-system)
     (arguments
      `(#:phases
@@ -3414,10 +3414,10 @@ consuming feeds in both RSS (Really Simple Syndication) and Atom format.")
          (add-before 'configure 'update-constraints
            (lambda _
              (substitute* "fgl.cabal"
-               (("QuickCheck >= 2\\.8 && < 2\\.10")
-                "QuickCheck >= 2.8 && < 2.12")
-               (("hspec >= 2\\.1 && < 2\\.5")
-                "hspec >= 2.1 && < 2.6")))))))
+               (("QuickCheck >= 2\\.8 && < 2\\.13")
+                "QuickCheck >= 2.8 && < 2.14")
+               (("hspec >= 2\\.1 && < 2\\.7")
+                "hspec >= 2.1 && < 2.8")))))))
     (inputs
      `(("ghc-hspec" ,ghc-hspec)
        ("ghc-quickcheck" ,ghc-quickcheck)))