summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:45:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:24 +0200
commit187391a65f0d43e56558915526e5d6c4d2d01151 (patch)
tree6b68f0c8241845abd8dd5e7447660f685b54b454 /gnu
parent3adf1d1ac3e831f82732764d1c073a7ec5e46a55 (diff)
downloadguix-187391a65f0d43e56558915526e5d6c4d2d01151.tar.gz
gnu: Add texlive-cweb-old.
* gnu/packages/tex.scm (texlive-cweb-old): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 148ebb9437..c14e54561d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1482,6 +1482,22 @@ with a wide array of formats.  For the moment, it works out of the box with
 ConTeXt and LaTeX.")
     (license (list license:gpl3+ license:fdl1.3+))))
 
+(define-public texlive-cweb-old
+  (package
+    (name "texlive-cweb-old")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "tex/plain/cweb-old/")
+             (base32
+              "0vx235zpflqpnrfa9kqq7wmc1rylg5bw1r26knfzvh3w1swbp4ai")))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/cweb-old")
+    (synopsis "Obsolete files from CWEB")
+    (description
+     "This package contains parts of CWEB that are no longer useful.")
+    (license license:knuth)))
+
 (define-public texlive-dosepsbin
   (package
     (name "texlive-dosepsbin")