summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-13 09:35:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:28 -0400
commit2d877f6ef3f59e152ae37d72ce150a442baeb7eb (patch)
treeaabbe633bb0363ec9c25cd7b1cfe25120e605269 /gnu
parent15b188c33dafc8ce6af142a740390e9507339526 (diff)
downloadguix-2d877f6ef3f59e152ae37d72ce150a442baeb7eb.tar.gz
gnu: Add ruby-css-parser.
* gnu/packages/ruby.scm (ruby-css-parser): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6a0ddd6719..c362500e8b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1191,6 +1191,27 @@ toolkit.")
     (home-page "https://github.com/jessedoyle/prawn-icon/")
     (license %prawn-project-licenses)))
 
+(define-public ruby-css-parser
+  (package
+    (name "ruby-css-parser")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "css_parser" version))
+       (sha256
+        (base32
+         "04c4dl8cm5rjr50k9qa6yl9r05fk9zcb1zxh0y0cdahxlsgcydfw"))))
+    (build-system ruby-build-system)
+    (arguments `(#:tests? #f))          ;gem doesn't ship with test suite
+    (propagated-inputs
+     `(("ruby-addressable" ,ruby-addressable)))
+    (synopsis "Ruby Cascading Style Sheets (CSS) parser")
+    (description "This package allows loading, parsing and cascading Cascading
+Style Sheets (CSS) rule sets in Ruby.")
+    (home-page "https://github.com/premailer/css_parser")
+    (license license:expat)))
+
 (define-public ruby-ast
   (package
     (name "ruby-ast")