summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-03-28 15:32:17 -0400
committerLeo Famulari <leo@famulari.name>2017-03-28 15:59:22 -0400
commit3061b33190b0e9b979255d70cbe3bc92a2e1e38d (patch)
tree392eca6d71c20bc5d120d53b02e1c4d6a4b98c5d /gnu
parent7f71e2579aca806be2fd30211fddeea69cafe31e (diff)
downloadguix-3061b33190b0e9b979255d70cbe3bc92a2e1e38d.tar.gz
gnu: Add python-sphinx@1.5.3.
* gnu/packages/python.scm (python-sphinx-1.5.3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e804da9025..ebb61f19b3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3102,6 +3102,22 @@ sources.")
     (license license:bsd-3)
     (properties `((python2-variant . ,(delay python2-sphinx))))))
 
+(define-public python-sphinx-1.5.3
+  (package
+    (inherit python-sphinx)
+    (name "python-sphinx")
+    (version "1.5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Sphinx" version))
+       (sha256
+        (base32
+         "0kw1axswbvaavr8ggyf4qr6hnisnrzlbkkcdada69vk1x9xjassg"))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest-3.0.7)
+       ,@(package-native-inputs python-sphinx)))))
+
 (define-public python2-sphinx
   (let ((base (package-with-python2 (strip-python2-variant python-sphinx))))
     (package