summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-13 11:32:25 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-13 11:32:25 +0100
commit31f9322e6fdecc6addcf8a67e0200bf1f457a7d7 (patch)
treee8a1d9e142030a3b03dbccb007b88de1eccf9154 /gnu
parenta31f4d35571376a0842aa3d044c4da12e17d3dbc (diff)
downloadguix-31f9322e6fdecc6addcf8a67e0200bf1f457a7d7.tar.gz
gnu: ffmpeg: Check via "make fate".
* gnu/packages/patches/ffmpeg-check.patch: Drop patch.
* gnu-system.am (dist_patch_DATA): Unregister patch.
* gnu/packages/video.scm (ffmpeg): Drop patch and use "fate" as test target
    as recommended at http://trac.ffmpeg.org/ticket/3177#comment:11 .
* gnu/packages/video.scm
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/ffmpeg-check.patch15
-rw-r--r--gnu/packages/video.scm8
2 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/patches/ffmpeg-check.patch b/gnu/packages/patches/ffmpeg-check.patch
deleted file mode 100644
index 0d4f879668..0000000000
--- a/gnu/packages/patches/ffmpeg-check.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-See https://trac.ffmpeg.org/ticket/3177 .
-
-diff --git a/libavcodec/cabac.c b/libavcodec/cabac.c
-index 29b188b..dff0a91 100644
---- a/libavcodec/cabac.c
-+++ b/libavcodec/cabac.c
-@@ -301,7 +301,7 @@ STOP_TIMER("get_cabac_bypass")
- 
-     for(i=0; i<SIZE; i++){
- START_TIMER
--        if( (r[i]&1) != get_cabac(&c, state) )
-+        if( (r[i]&1) != get_cabac_noinline(&c, state) )
-             av_log(NULL, AV_LOG_ERROR, "CABAC failure at %d\n", i);
- STOP_TIMER("get_cabac")
-     }
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 563ff3cb77..199f7c2c74 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -21,7 +21,6 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages fontutils)
@@ -42,9 +41,7 @@
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1qnspbpwa6cflsb6mkm84ay4nfx60ism6d7lgvnasidck9dmxydy"))
-             ;; from upstream, drop with next release
-             (patches (list (search-patch "ffmpeg-check.patch")))))
+               "1qnspbpwa6cflsb6mkm84ay4nfx60ism6d7lgvnasidck9dmxydy"))))
     (build-system gnu-build-system)
     (inputs
      `(("bc" ,bc)
@@ -60,7 +57,8 @@
        ("yasm" ,yasm)
        ("zlib", zlib)))
     (arguments
-     `(#:phases
+     `(#:test-target "fate"
+       #:phases
          (alist-replace
           'configure
           ;; configure does not work followed by "SHELL=..." and