summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2017-07-31 14:57:21 +0100
committerLudovic Courtès <ludo@gnu.org>2017-08-21 17:04:54 +0200
commit327404aeaa4a431188a24eb697c37e4d5c5b428f (patch)
tree4acc9bb8ccefd372e444f0d8b85049839d2cb61b /gnu
parent685bef2bd1d92678c7f7104fee9f6e46438d88f8 (diff)
downloadguix-327404aeaa4a431188a24eb697c37e4d5c5b428f.tar.gz
gnu: openmpi: Remove "static" output.
--enable-static removes dynamically-loaded MCA components.

* gnu/packages/mpi.scm (openmpi)[outputs]: Remove field.
[arguments]: Don't configure with --enable-static; remove
'move-static-libraries' phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mpi.scm19
1 files changed, 1 insertions, 18 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index ac7b9b2545..f24da7b661 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -122,7 +122,6 @@ bind processes, and much more.")
        (base32
         "142s1vny9gllkq336yafxayjgcirj2jv0ddabj879jgya7hyr2d0"))))
     (build-system gnu-build-system)
-    (outputs '("out" "static"))
     (inputs
      `(("hwloc" ,hwloc "lib")
        ("gfortran" ,gfortran)
@@ -133,9 +132,7 @@ bind processes, and much more.")
      `(("pkg-config" ,pkg-config)
        ("perl" ,perl)))
     (arguments
-     `(#:configure-flags `("--enable-static"
-
-                           "--enable-builtin-atomics"
+     `(#:configure-flags `("--enable-builtin-atomics"
 
                            "--enable-mpi-ext=all"
                            "--with-devel-headers"
@@ -157,20 +154,6 @@ bind processes, and much more.")
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let ((out (assoc-ref outputs "out")))
                         (for-each delete-file (find-files out "config.log"))
-                        #t)))
-                  (add-after 'install 'move-static-libraries
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      ;; Move 19 MiB of static libraries to 'static'.
-                      (let* ((out    (assoc-ref outputs "out"))
-                             (static (assoc-ref outputs "static"))
-                             (lib    (string-append out "/lib"))
-                             (slib   (string-append static "/lib")))
-                        (mkdir-p slib)
-                        (for-each (lambda (file)
-                                    (rename-file
-                                     file
-                                     (string-append slib "/" (basename file))))
-                                  (find-files lib "\\.a$"))
                         #t))))))
     (home-page "http://www.open-mpi.org")
     (synopsis "MPI-3 implementation")