summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-01-16 17:34:22 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-16 17:35:29 +0100
commit3b1ada0d715202de644af0e8978b29e9b5e33de7 (patch)
treef0ccf71b87692952d6f66553e18a30ec8e2a30ce /gnu
parent531003be6b719526c05b06286b7313621c6ddc41 (diff)
downloadguix-3b1ada0d715202de644af0e8978b29e9b5e33de7.tar.gz
gnu: Add curlftpfs.
* gnu/packages/file-systems.scm (curlftpfs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/file-systems.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 621c70b0d5..4a8058b520 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -32,11 +32,13 @@
   #:use-module (gnu packages bison)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -206,3 +208,38 @@ consumption needs.  It incorporates automatic failover as a primary feature.
 All of this is accomplished without a centralized metadata server.")
     ;; The user may choose either LGPLv3+ or GPLv2 only.
     (license (list license:lgpl3+ license:gpl2+))))
+
+(define-public curlftpfs
+  (package
+    (name "curlftpfs")
+    (version "0.9.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/curlftpfs/curlftpfs/" version
+                           "/curlftpfs-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0n397hmv21jsr1j7zx3m21i7ryscdhkdsyqpvvns12q7qwwlgd2f"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-test
+           (lambda _
+             ;; One of the 512-Byte block counts is definitely wrong.
+             ;; See <https://sourceforge.net/p/curlftpfs/bugs/73/>.
+             (substitute* "tests/ftpfs-ls_unittest.c"
+              (("4426192") "12814800"))
+             #t)))))
+    (inputs
+     `(("curl" ,curl)
+       ("glib" ,glib)
+       ("fuse", fuse)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://curlftpfs.sourceforge.net/")
+    (synopsis "Mount remote file systems over FTP")
+    (description
+     "This is a file system client based on the FTP File Transfer Protocol.")
+    (license license:gpl2+)))