summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-04-01 18:55:28 -0400
committerMark H Weaver <mhw@netris.org>2014-04-02 11:28:26 -0400
commit3b9af0f37b6a8ea7a0d05809f78accb78a6d8207 (patch)
tree139f366c8861209b7b53747ed14b06ae70eff8f8 /gnu
parent56fab253e3847af20412044932b428db733936ef (diff)
downloadguix-3b9af0f37b6a8ea7a0d05809f78accb78a6d8207.tar.gz
gnu: bazaar: Install man pages in share/man.
* gnu/packages/version-control.scm (bazaar): Add a phase that
  fixes setup.py to install man pages in share/man.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ef08bbe5e8..f63df4a2ff 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -63,8 +64,14 @@
      `(("gettext" ,gnu-gettext)))
     (arguments
      `(#:tests? #f ; no test target
-       #:python ,python-2)) ; Python 3 apparently not yet supported, see
+       #:python ,python-2   ; Python 3 apparently not yet supported, see
                             ; https://answers.launchpad.net/bzr/+question/229048
+       #:phases (alist-cons-after
+                 'unpack 'fix-mandir
+                 (lambda _
+                   (substitute* "setup.py"
+                     (("man/man1") "share/man/man1")))
+                 %standard-phases)))
     (home-page "https://gnu.org/software/bazaar")
     (synopsis "Version control system supporting both distributed and centralized workflows")
     (description