summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-27 00:06:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-27 00:16:58 +0100
commit3d5806ed6cf9f8020a25a13b3e2f5c4e479d4529 (patch)
treef59fb4a5a008233317d184058f1016ca2f2ac618 /gnu
parent2f84a58d3b2d3bfbc460f9eaba029b457ad8af4a (diff)
downloadguix-3d5806ed6cf9f8020a25a13b3e2f5c4e479d4529.tar.gz
gnu: powertabeditor: Update to 2.0.0-alpha14.
* gnu/packages/music.scm (powertabeditor): Update to 2.0.0-alpha14.
[arguments]: Add phase "fix-pugixml-detection".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c85957352a..8fcc22f26d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1748,7 +1748,7 @@ your own lessons.")
 (define-public powertabeditor
   (package
     (name "powertabeditor")
-    (version "2.0.0-alpha13")
+    (version "2.0.0-alpha14")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1757,12 +1757,17 @@ your own lessons.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "12il5xzgg53ick5k4ivvvqdagld5pgigiiz6s829kkdaymqr7vx5"))))
+                "1wsvni2aa9h2bpndlic7ckch4n600ahwm56n521y5vxivwjx3jmj"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (replace 'check (lambda _ (invoke "bin/pte_tests"))))))
+         (replace 'check (lambda _ (invoke "bin/pte_tests")))
+         (add-after 'unpack 'fix-pugixml-detection
+           (lambda _
+             (substitute* "cmake/third_party/pugixml.cmake"
+               (("add_library") "#add_library"))
+             #t)))))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("boost" ,boost)