summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-04-22 11:39:49 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-05-13 17:31:19 +0200
commit4002e0dfc42fb115b9fb2479e4a5308844d8d489 (patch)
tree9ce45d6df8393340cec48a687494747d907331d0 /gnu
parent620aa440d814bef73d81a1a847439532029e4aa5 (diff)
downloadguix-4002e0dfc42fb115b9fb2479e4a5308844d8d489.tar.gz
gnu: Add alsa-topology-conf.
* gnu/packages/linux.scm (alsa-topology-conf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 086b9607f6..2d992e2a9d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2207,6 +2207,29 @@ configuration of audio input/output names and routing for specific audio
 hardware.")
     (license license:bsd-3)))
 
+(define-public alsa-topology-conf
+  (package
+    (name "alsa-topology-conf")
+    (version "1.2.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "ftp://ftp.alsa-project.org/pub/lib/" name "-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "01zdg6q4s6d01k39z96wi4vbhrfw1i2g4yi5dijwfk6a5vjfdq2m"))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan
+       '(("topology" "share/alsa/topology"))))
+    (home-page "https://www.alsa-project.org/wiki/Main_Page")
+    (synopsis "The Advanced Linux Sound Architecture libraries")
+    (description
+     "This package contains Advanced Linux Sound Architecture topology
+configuration files that can be used for specific audio hardware.")
+    (license license:bsd-3)))
+
 (define-public alsa-lib
   (package
     (name "alsa-lib")