summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:07 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:09 +0300
commit450185df4e846abc666532e31dbb9a43ba6eb8d4 (patch)
tree6bbba61e87885f5573f62fbc06f33834c003daec /gnu
parent2f9173430f0b72c59313bc8f7943d305364bfe3a (diff)
downloadguix-450185df4e846abc666532e31dbb9a43ba6eb8d4.tar.gz
gnu: python-extension-helpers: Update to 1.0.0.
* gnu/packages/python-xyz.scm (python-extension-helpers): Update to
1.0.0.
[build-system]: Use pyproject-build-system.
[arguments]<tests>: Disable them, as pytest can't load the test suite.
[native-inputs]: Add python-setuptools-scm.
[home-page]: Re-point to actual project home page.
[synopsis]: Adjust it to cover actual project.
[description]: ... as above.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a5c99a6f20..1417031788 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3690,23 +3690,30 @@ and is not compatible with JSON.")
 (define-public python-extension-helpers
 (package
   (name "python-extension-helpers")
-  (version "0.1")
+  (version "1.0.0")
   (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "extension-helpers" version))
       (sha256
-        (base32 "10iqjzmya2h4sk765dlm1pbqypwlqyh8rw59a5m9i63d3klnz2mc"))))
-  (build-system python-build-system)
+        (base32 "1rjha07ds633fb81hn3i2yzk3v2flbi6qa091ix4mkvrgk3gl6ya"))))
+  (build-system pyproject-build-system)
+  ;; FIXME: pytest failed to load test suit, find out why.
+  ;;  - _pytest.pathlib.ImportPathMismatchError: ('extension_helpers.conftes
+  (arguments (list #:tests? #f))
   (native-inputs
-    (list python-coverage python-pytest-astropy python-pytest-cov
+    (list python-coverage
+          python-pytest
+          python-pytest-astropy
+          python-pytest-cov
           python-setuptools-scm))
-  (home-page "https://github.com/astropy/astropy-helpers")
-  (synopsis
-   "Utilities for building and installing packages in the Astropy ecosystem")
+  (home-page "https://extension-helpers.readthedocs.io")
+  (synopsis "Astropy ecosystem utilities for building and installing packages")
   (description
-    "The extension-helpers package includes many build, installation, and
-documentation-related tools used by the Astropy project.")
+    "The extension-helpers package includes convenience helpers to assist with
+building Python packages with compiled C/Cython extensions.  It is developed by
+the Astropy project but is intended to be general and usable by any Python
+package.")
   (license license:bsd-3)))
 
 (define-public python-extras