summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-21 23:12:04 -0400
committerMark H Weaver <mhw@netris.org>2015-04-22 15:08:45 -0400
commit4788deea0b029dedc8657a5175e89bc8eab3f27b (patch)
tree8e13a6b468554f39bf73dddb7206b0df1f2a9713 /gnu
parentf0d6d83552c08fb35f6aaf8b46876be55e73a37c (diff)
downloadguix-4788deea0b029dedc8657a5175e89bc8eab3f27b.tar.gz
gnu: nginx: Fix configure flags on unsupported platforms.
* gnu/packages/web.scm (nginx)[arguments]: Add default case in 'match' form
  within 'configure' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0c22562aa6..519a91e160 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -132,7 +132,12 @@ and its related documentation.")
                                                      (%current-system))
                                             ("x86_64-linux"   "x86_64")
                                             ("i686-linux"     "i686")
-                                            ("mips64el-linux" "mips64"))))
+                                            ("mips64el-linux" "mips64")
+                                            ;; Prevent errors when querying
+                                            ;; this package on unsupported
+                                            ;; platforms, e.g. when running
+                                            ;; "guix package --search="
+                                            (_                "UNSUPPORTED"))))
                              (string-append "--crossbuild="
                                             system ":" release ":" machine)))))
                (setenv "CC" "gcc")