summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2022-02-07 09:26:30 -0500
committerLudovic Courtès <ludo@gnu.org>2022-02-08 13:34:03 +0100
commit4be896d6e0d322b3f5b514c8a2811efcd6a31606 (patch)
treeb190bfc73e207a970ba4151c1149d1584aa62672 /gnu
parentc491338bcb643af03f2c92e2a2c010e613fc74c9 (diff)
downloadguix-4be896d6e0d322b3f5b514c8a2811efcd6a31606.tar.gz
gnu: iwd: Update to 1.24.
* gnu/packages/linux.scm (ell): Update to 0.48.
[arguments]: Remove obsolete "fix-dbus-tests" phase.
* gnu/packages/networking.scm (iwd): Update to 1.24.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm14
-rw-r--r--gnu/packages/networking.scm4
2 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b50f2e9c5b..254a97e915 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8384,7 +8384,7 @@ tools for managing PipeWire.")
 (define-public ell
   (package
     (name "ell")
-    (version "0.46")
+    (version "0.48")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -8393,18 +8393,8 @@ tools for managing PipeWire.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "15hwqicmll23cbrj13h3wd4lgrby416ap7l6w0434jsza4s4yv82"))))
+                "0lxjizby3zdyhzad5a0gbz4m2pp44jf1j4l1pn18d04rw9mr2gqy"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-dbus-tests
-           (lambda _
-             (substitute* '("unit/test-dbus-message-fds.c"
-                            "unit/test-dbus-properties.c"
-                            "unit/test-dbus.c")
-               (("/usr/bin/dbus-daemon") (which "dbus-daemon")))
-             #t)))))
     (inputs
      (list dbus))
     (native-inputs
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 382b4cf96d..4d260249d7 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3563,7 +3563,7 @@ powerful route filtering syntax and an easy-to-use configuration interface.")
 (define-public iwd
   (package
     (name "iwd")
-    (version "1.20")
+    (version "1.24")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3572,7 +3572,7 @@ powerful route filtering syntax and an easy-to-use configuration interface.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0xlbnsgw9giakfj0xr526i7mcwyaryb18g66mv90njnrm8radjhr"))))
+                "1sdi7008j5jhlg2rqpczh1pzb8zay6mc9dpnjjsmdnsmrcr3v7wi"))))
     (build-system gnu-build-system)
     (inputs
      (list dbus ell (package-source ell) readline))