summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-27 10:02:16 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-27 10:05:33 -0500
commit5a1a4bf6b2cc2a7652d0c9199b22af6297b78f7e (patch)
tree645f289b7e6334a49846178187e18573a379438c /gnu
parentc1448c69747c7e8bd2a2e911b96c7f2837fee691 (diff)
downloadguix-5a1a4bf6b2cc2a7652d0c9199b22af6297b78f7e.tar.gz
gnu: Add python-mock.
* gnu/packages/python.scm (python-mock): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 53d1f3edb4..b15e5b66d2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -317,6 +317,31 @@ API for locking files.")
 (define-public python2-lockfile
   (package-with-python2 python-lockfile))
 
+(define-public python-mock
+  (package
+    (name "python-mock")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://pypi.python.org/packages/source/m/mock/"
+                           "mock-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0kzlsbki6q0awf89rc287f3aj8x431lrajf160a70z0ikhnxsfdq"))))
+    (build-system python-build-system)
+    (arguments '(#:test-target "check"))
+    (home-page "http://code.google.com/m/mock/")
+    (synopsis "A Python Mocking and Patching Library for Testing")
+    (description
+     "Mock is a library for testing in Python.  It allows you to replace parts
+of your system under test with mock objects and make assertions about how they
+have been used.")
+    (license expat)))
+
+(define-public python2-mock
+  (package-with-python2 python-mock))
+
 
 (define-public python-setuptools
   (package