summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 10:00:51 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 10:00:51 +0200
commit5aa68a9408e7af7dfb38abf48e499788fb7b0f82 (patch)
treec4371f34456413e4f823c9a410973cbe35cc8cb1 /gnu
parent3f2a4b098039bd374c76d524223de3c6c475f23e (diff)
downloadguix-5aa68a9408e7af7dfb38abf48e499788fb7b0f82.tar.gz
gnu: Add r-model4you.
* gnu/packages/cran.scm (r-model4you): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 949c74f0e8..b8417ec974 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1157,6 +1157,36 @@ the embedded @code{RapidXML} C++ library.")
     ;; 'rapidxml' which is Boost.
     (license (list license:gpl3 license:bsd-2 license:boost1.0))))
 
+(define-public r-model4you
+  (package
+    (name "r-model4you")
+    (version "0.9-7")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "model4you" version))
+              (sha256
+               (base32
+                "0pni9v3nradvy8sp2m07903vc7z610xrh426lf19dxss12kgrfi8"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-formula" ,r-formula)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-gridextra" ,r-gridextra)
+       ("r-partykit" ,r-partykit)
+       ("r-sandwich" ,r-sandwich)
+       ("r-survival" ,r-survival)))
+    (home-page "https://cran.r-project.org/web/packages/model4you/")
+    (synopsis "Stratified and personalised models based on trees and forests")
+    (description
+     "This package provides procedures for model-based trees for subgroup
+analyses in clinical trials and model-based forests for the estimation and
+prediction of personalised treatment effects.  Currently partitioning of linear
+models, @code{lm()}, generalised linear models, @code{glm()}, and
+Weibull models, @code{survreg()}, are supported.  Advanced plotting functionality is
+supported for the trees and a test for parameter heterogeneity is provided for
+the personalised models.")
+    (license license:gpl2+)))
+
 (define-public r-modelr
   (package
     (name "r-modelr")