summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-02 13:33:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-02 13:33:16 +0200
commit5caad9f2526a352fbe78ba3c687ab8bf20162ca0 (patch)
tree40c88d8ce0d75d87d66811d14dd4de5458d2a006 /gnu
parent9dafaf163574edca5cb4eac0f8dc3edbb0ef0a75 (diff)
downloadguix-5caad9f2526a352fbe78ba3c687ab8bf20162ca0.tar.gz
gnu: python-cooler: Use more recent cytoolz.
* gnu/packages/bioinformatics.scm (python-cooler)[propagated-inputs]: Replace
python-cytoolz-for-cooler with python-cytoolz.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 40ccba247c..4a3600fd0c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12652,6 +12652,13 @@ fasta subsequences.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         ;; cooler requests cytoolz<0.11.  It only uses cytoolz for "compose",
+         ;; which composes two functions.
+         (add-after 'unpack 'use-recent-cytoolz
+           (lambda _
+             (substitute* '("requirements.txt"
+                            "cooler.egg-info/requires.txt")
+               (("cytoolz.*<.*0.11") "cytoolz"))))
          (add-after 'unpack 'patch-tests
            (lambda _
              (substitute* "tests/test_create.py"
@@ -12677,7 +12684,7 @@ fasta subsequences.")
      (list python-asciitree
            python-biopython
            python-click
-           python-cytoolz-for-cooler
+           python-cytoolz
            python-dask
            python-h5py
            python-multiprocess