summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2014-03-31 20:18:52 +0200
committerCyril Roelandt <tipecaml@gmail.com>2014-04-01 00:48:25 +0200
commit6050a1fb30378b46bf443efd8e99ac310f8356eb (patch)
treea9931d1b216703919f8eda73cd9f51d0c083ee5e /gnu
parente4687a5e68fce458685dd33bfa240758c816b3a2 (diff)
downloadguix-6050a1fb30378b46bf443efd8e99ac310f8356eb.tar.gz
gnu: Add guile-json.
* gnu/packages/guile.scm (guile-json): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index d1ea6e8fd0..5132a117a8 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -326,4 +326,28 @@ for Guile\".")
     ;; details.
     (license gpl3+)))
 
+(define-public guile-json
+  (package
+    (name "guile-json")
+    (version "0.3.1")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://savannah/guile-json/guile-json-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "0nz2sx61kd6cfflwzxxq0cb9dz0asb81abbhfawv4p9ghciqdr3g"))))
+    (build-system gnu-build-system)
+    (inputs `(("guile" ,guile-2.0)))
+    (home-page "http://savannah.nongnu.org/projects/guile-json/")
+    (synopsis "JSON module for Guile")
+    (description
+     "Guile-json supports parsing and building JSON documents according to the
+http:://json.org specification. These are the main features:
+- Strictly complies to http://json.org specification.
+- Build JSON documents programmatically via macros.
+- Unicode support for strings.
+- Allows JSON pretty printing.")
+    (license lgpl3+)))
+
 ;;; guile.scm ends here