summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-01-11 13:24:43 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-03-17 23:15:57 -0400
commit667c6ef51606ab39a8e8d849d3dcd09f8ee36e00 (patch)
tree7cc825159fa84098b9984b03936371a3a411d819 /gnu
parenta042d348c255d8d1a0af41b55cb66755f09bcf10 (diff)
downloadguix-667c6ef51606ab39a8e8d849d3dcd09f8ee36e00.tar.gz
gnu: python-pandas: Enable Excel file format support.
* gnu/packages/python.scm (python-pandas)[phases]{check}: Re-instate the tests
  from the test_excel.py module.
* gnu/packages/python.scm (python-pandas)[propagated-inputs]: Add
  python-openpyxl and python-xlrd.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bc8375dc57..a1e7bc8831 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1043,7 +1043,6 @@ human-friendly syntax.")
                                     '("pandas/tests/io/conftest.py"
                                       "pandas/tests/io/json/test_compression.py"
                                       "pandas/tests/io/parser/test_network.py"
-                                      "pandas/tests/io/test_excel.py"
                                       "pandas/tests/io/test_parquet.py"))
                           (invoke "pytest" "-vv" "pandas" "--skip-slow"
                                   "--skip-network" "-k"
@@ -1051,8 +1050,10 @@ human-friendly syntax.")
                                   "not test_read_s3_jsonl"))))))))
     (propagated-inputs
      `(("python-numpy" ,python-numpy)
+       ("python-openpyxl" ,python-openpyxl)
        ("python-pytz" ,python-pytz)
-       ("python-dateutil" ,python-dateutil)))
+       ("python-dateutil" ,python-dateutil)
+       ("python-xlrd" ,python-xlrd)))
     (native-inputs
      `(("python-cython" ,python-cython)
        ("python-beautifulsoup4" ,python-beautifulsoup4)