summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-11-14 15:21:46 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-11-14 16:36:58 -0800
commit6cdf4e5bf230fdbe17e592c2ec74fb34dba70eb5 (patch)
treeb6b0e531b172b4c0d14b6f7593314833403d3176 /gnu
parente6e6b5124b0b630c648009c9c3f942796267d766 (diff)
downloadguix-6cdf4e5bf230fdbe17e592c2ec74fb34dba70eb5.tar.gz
gnu: gd: Fix long patch filename.
This fixes the generation of a tarball with "make dist":

  tar: guix-1.3.0.10365-4c4f9/gnu/packages/patches/gd-Revert-fix-303-gdlib.pc-use-Requires-instead-of-Libs.patch:
  file name is too long (max 99); not dumped

* gnu/packages/patches/gd-Revert-fix-303-gdlib.pc-use-Requires-instead-of-Libs.patch:
  Rename patch to ...
* gnu/packages/patches/gd-Revert-fix-303-gdlib.pc.patch: ... this.
* gnu/packages/gd.scm (gd)[source]: Update patch filename.
* gnu/local.mk (dist_patch_DATA): Update patch filename.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/gd.scm2
-rw-r--r--gnu/packages/patches/gd-Revert-fix-303-gdlib.pc.patch (renamed from gnu/packages/patches/gd-Revert-fix-303-gdlib.pc-use-Requires-instead-of-Libs.patch)0
3 files changed, 2 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7851f43a5b..70af4a8570 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1123,7 +1123,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/gcc-9-strmov-store-file-names.patch	\
   %D%/packages/patches/gd-fix-tests-on-i686.patch		\
   %D%/packages/patches/gd-brect-bounds.patch			\
-  %D%/packages/patches/gd-Revert-fix-303-gdlib.pc-use-Requires-instead-of-Libs.patch	\
+  %D%/packages/patches/gd-Revert-fix-303-gdlib.pc.patch		\
   %D%/packages/patches/gdm-default-session.patch		\
   %D%/packages/patches/gdm-elogind-support.patch		\
   %D%/packages/patches/gdm-remove-hardcoded-xwayland-path.patch	\
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index e37c485761..1bd53a3b20 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -57,7 +57,7 @@
                               ;; Drop when
                               ;; https://github.com/libgd/libgd/issues/691
                               ;; is solved.
-                              "gd-Revert-fix-303-gdlib.pc-use-Requires-instead-of-Libs.patch"))))
+                              "gd-Revert-fix-303-gdlib.pc.patch"))))
     (build-system gnu-build-system)
     (arguments
       ;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
diff --git a/gnu/packages/patches/gd-Revert-fix-303-gdlib.pc-use-Requires-instead-of-Libs.patch b/gnu/packages/patches/gd-Revert-fix-303-gdlib.pc.patch
index 6329b129d3..6329b129d3 100644
--- a/gnu/packages/patches/gd-Revert-fix-303-gdlib.pc-use-Requires-instead-of-Libs.patch
+++ b/gnu/packages/patches/gd-Revert-fix-303-gdlib.pc.patch