summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-02-12 21:12:54 +0800
committer宋文武 <iyzsong@gmail.com>2015-02-19 10:32:56 +0800
commit6f96a359ebb349527dd2e1d9c62a18f84bc2d164 (patch)
tree254ad13352be8e104049bbac47255cb572efbaa4 /gnu
parentc1944c92724cb1c1192c830a89501009a73431b0 (diff)
downloadguix-6f96a359ebb349527dd2e1d9c62a18f84bc2d164.tar.gz
gnu: Add libxklavier.
* gnu/packages/gnome.scm (libxklavier): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c42092d28e..73fb7f50dc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1514,3 +1515,49 @@ serialization and deserialization support for the JavaScript Object Notation
 GObject classes and various wrappers for the complex data types employed by
 JSON, such as arrays and objects.")
     (license license:lgpl2.1+)))
+
+(define-public libxklavier
+  (package
+    (name "libxklavier")
+    (version "5.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  version "/" name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "016lpdv35z0qsw1cprdc2k5qzkdi5waj6qmr0a2q6ljn9g2kpv7b"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags
+       (list (string-append "--with-xkb-base="
+                            (assoc-ref %build-inputs "xkeyboard-config")
+                            "/share/X11/xkb"))
+       #:phases
+       (alist-cons-before
+        'build 'set-cc
+        (lambda _
+          (setenv "CC" "gcc")) ; for g-ir-scanner.
+        %standard-phases)))
+    (native-inputs
+     `(("glib:bin"              ,glib "bin") ; for glib-mkenums, etc.
+       ("gobject-introspection" ,gobject-introspection)
+       ("pkg-config"            ,pkg-config)))
+    (propagated-inputs
+     ;; Required by libxklavier.pc.
+     `(("glib"    ,glib)
+       ("libxml2" ,libxml2)))
+    (inputs
+     `(("iso-codes"        ,iso-codes)
+       ("libxi"            ,libxi)
+       ("libxkbfile"       ,libxkbfile)
+       ("xkbcomp"          ,xkbcomp)
+       ("xkeyboard-config" ,xkeyboard-config)))
+    (home-page "http://www.freedesktop.org/wiki/Software/LibXklavier/")
+    (synopsis "High-level API for X Keyboard Extension")
+    (description
+     "LibXklavier is a library providing high-level API for X Keyboard
+Extension known as XKB.  This library is indended to support XFree86 and other
+commercial X servers. It is useful for creating XKB-related software (layout
+indicators etc).")
+    (license license:lgpl2.0+)))