summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-29 08:49:45 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-29 09:25:51 +0200
commit77fe306c66eea88acd4b29dd0e60bbf9d7bae101 (patch)
treea7343c1df74c02c697e54650642cfc6e3a2b6263 /gnu
parentd64d6ea2cf5a1be801be355031fb2cfa5901a92a (diff)
downloadguix-77fe306c66eea88acd4b29dd0e60bbf9d7bae101.tar.gz
gnu: avahi: Support for cross-building and the Hurd.
* gnu/packages/avahi.scm (avahi)[inputs]: Include libcap only for supported
systems and when not cross-building.
[arguments]: Add --disable-autoipd when not using libcap.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/avahi.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index 65d3ede131..a2b5f256bc 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -73,6 +74,12 @@
                            "--enable-compat-libdns_sd"
                            ,@(if (%current-target-system)
                                  '("ac_cv_prog_have_pkg_config=yes")
+                                 '())
+                           ,@(if (or (%current-target-system)
+                                     (not (member (%current-system)
+                                                  (package-supported-systems
+                                                   libcap))))
+                                 '("--disable-autoipd")
                                  '()))
        #:modules ((srfi srfi-26)
                   (guix build utils)
@@ -92,7 +99,13 @@
        ("expat" ,expat)
        ("gdbm" ,gdbm)
        ("glib" ,glib)
-       ("libcap" ,libcap)            ;to enable chroot support in avahi-daemon
+       ;; Do not use libcap when cross-compiling since it's not quite
+       ;; cross-compilable; and use it only for supported systems.
+       ,@(if (and (not (%current-target-system))
+                  (member (%current-system)
+                          (package-supported-systems libcap)))
+             `(("libcap" ,libcap))   ;to enable chroot support in avahi-daemon
+             '())
        ("libdaemon" ,libdaemon)
        ("libevent" ,libevent)))
     (native-inputs