summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@gmail.com>2020-06-04 12:42:30 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-04 22:13:20 +0200
commit80cd90ef30e78e3b483ee1d00993c9a9a4a096ac (patch)
tree21aa5cbfb00413b3e7e63e7b0beec0c0c6f7e857 /gnu
parent790ada9168e0689c1c4607c61cdc1d2dbc327abf (diff)
downloadguix-80cd90ef30e78e3b483ee1d00993c9a9a4a096ac.tar.gz
gnu: Add emacs-meson-mode.
* gnu/packages/emacs-xyz.scm (emacs-meson-mode): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 87797aabcc..188ecf45b6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22671,6 +22671,28 @@ two user-defined directories, as well as using more descriptive names for
 files and subdirectories when appropriate.")
     (license license:gpl3+)))
 
+(define-public emacs-meson-mode
+  (package
+    (name "emacs-meson-mode")
+    (version "0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/wentasah/meson-mode.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1720b3hpfqd989zrgcns51jbjrv4vzl9di9mccl55vkmkbqzfin0"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/wentasah/meson-mode")
+    (synopsis "Major mode for Meson build system files")
+    (description
+     "This is an Emacs major mode for Meson build system files.  Syntax
+highlighting works reliably.  Indentation works too, but there are probably
+cases where it breaks.")
+    (license license:gpl3+)))
+
 (define-public emacs-message-x
   ;; Use the latest commit, as there are no tagged releases.
   (let ((commit "5524de7bbfdd8749c110f48de5afb024d9f83133")