summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-14 09:12:54 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-20 11:16:34 +0200
commit812ce80adaa0e2174ca9ee6c3a0fc9e2d6e6d0bd (patch)
treea651fa51404ab390b7a21c8fe9a03116d3f8f531 /gnu
parent6b35ddf612c6edfdc9231134976f0af8d13fc424 (diff)
downloadguix-812ce80adaa0e2174ca9ee6c3a0fc9e2d6e6d0bd.tar.gz
gnu: Update rust-rand-core-0.5 to 0.5.1.
* gnu/packages/crates-io.scm (rust-rand-core-0.5): Update to 0.5.1.
[arguments]: Remove rust-serde-derive-1.0 from cargo-inputs.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 10e19d4114..72bc1ad642 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7733,7 +7733,7 @@ useful types and distributions, and some randomness-related algorithms.")
 (define-public rust-rand-core-0.5
   (package
     (name "rust-rand-core")
-    (version "0.5.0")
+    (version "0.5.1")
     (source
      (origin
        (method url-fetch)
@@ -7742,14 +7742,13 @@ useful types and distributions, and some randomness-related algorithms.")
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "1jis94x9ri8xlxki2w2w5k29sjpfwgzkjylg7paganp74hrnhpk1"))))
+         "06bdvx08v3rkz451cm7z59xwwqn1rkfh6v9ay77b14f8dwlybgch"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-getrandom" ,rust-getrandom-0.1)
-        ("rust-serde" ,rust-serde-1.0)
-        ("rust-serde-derive" ,rust-serde-derive-1.0))))
+        ("rust-serde" ,rust-serde-1.0))))
     (home-page "https://crates.io/crates/rand-core")
     (synopsis
      "Core random number generator traits and tools for implementation")