summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-20 15:01:51 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-20 15:03:10 +0200
commit86f1537d3f5a3336232af6e9406cf0b887271c72 (patch)
tree89156657dca9f2e772651797cef750f20b86cf44 /gnu
parent124b7f1e0fa7504b308b59d764c4e70605533ee0 (diff)
downloadguix-86f1537d3f5a3336232af6e9406cf0b887271c72.tar.gz
gnu: Move non-X11 fonts from module xorg to fonts.
* gnu/packages/fonts.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add module fonts.
* gnu/packages/xorg.scm (font-bitstream-vera-ttf): Move this...
* gnu/packages/fonts.scm (ttf-bitstream-vera): ...to this.
* gnu/packages/xorg.scm (freefont-ttf): Move this...
* gnu/packages/fonts.scm (freefont-ttf): ...to this.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fonts.scm133
-rw-r--r--gnu/packages/xorg.scm110
2 files changed, 133 insertions, 110 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
new file mode 100644
index 0000000000..c367a46e4a
--- /dev/null
+++ b/gnu/packages/fonts.scm
@@ -0,0 +1,133 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fonts)
+  #:use-module ((guix licenses)
+                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system trivial)
+  #:use-module ((gnu packages base)
+                #:select (tar))
+  #:use-module (gnu packages compression))
+
+(define-public ttf-bitstream-vera
+  (package
+    (name "ttf-bitstream-vera")
+    (version "1.10")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnome/sources/ttf-bitstream-vera/"
+                                 version "/ttf-bitstream-vera-"
+                                 version ".tar.bz2"))
+             (sha256
+              (base32
+               "1p3qs51x5327gnk71yq8cvmxc6wgx79sqxfvxcv80cdvgggjfnyv"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder (begin
+                   (use-modules (guix build utils)
+                                (srfi srfi-26))
+
+                   (let ((tar      (string-append (assoc-ref %build-inputs
+                                                             "tar")
+                                                  "/bin/tar"))
+                         (PATH     (string-append (assoc-ref %build-inputs
+                                                             "bzip2")
+                                                  "/bin"))
+                         (font-dir (string-append %output
+                                                  "/share/fonts/truetype"))
+                         (doc-dir  (string-append %output "/share/doc/"
+                                                  ,name "-" ,version)))
+                     (setenv "PATH" PATH)
+                     (system* tar "xvf" (assoc-ref %build-inputs "source"))
+
+                     (mkdir-p font-dir)
+                     (mkdir-p doc-dir)
+                     (chdir (string-append "ttf-bitstream-vera-" ,version))
+                     (for-each (lambda (ttf)
+                                 (copy-file ttf
+                                            (string-append font-dir "/" ttf)))
+                               (find-files "." "\\.ttf$"))
+                     (for-each (lambda (doc)
+                                 (copy-file doc
+                                            (string-append doc-dir "/" doc)))
+                               (find-files "." "\\.TXT$"))))))
+    (native-inputs `(("source" ,source)
+                     ("tar" ,tar)
+                     ("bzip2" ,bzip2)))
+    (home-page "https://www-old.gnome.org/fonts/")
+    (synopsis "Bitstream Vera sans-serif typeface")
+    (description "Vera is a sans-serif typeface from Bitstream, Inc.  This
+package provides the TrueType (TTF) files.")
+    (license
+     (license:x11-style
+      "https://www-old.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
+
+(define-public freefont-ttf
+  (package
+    (name "freefont-ttf")
+    (version "20100919")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/freefont/freefont-ttf-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "1q3h5jp1mbdkinkwxy0lfd0a1q7azlbagraydlzaa2ng82836wg4"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder (begin
+                   (use-modules (guix build utils)
+                                (srfi srfi-26))
+
+                   (let ((tar      (string-append (assoc-ref %build-inputs
+                                                             "tar")
+                                                  "/bin/tar"))
+                         (PATH     (string-append (assoc-ref %build-inputs
+                                                             "gzip")
+                                                  "/bin"))
+                         (font-dir (string-append %output
+                                                  "/share/fonts/truetype"))
+                         (doc-dir  (string-append %output "/share/doc/"
+                                                  ,name "-" ,version)))
+                     (setenv "PATH" PATH)
+                     (system* tar "xvf" (assoc-ref %build-inputs "source"))
+
+                     (mkdir-p font-dir)
+                     (mkdir-p doc-dir)
+                     (chdir (string-append "freefont-" ,version))
+                     (for-each (lambda (file)
+                                 (let ((dir (if (string-suffix? "ttf" file)
+                                                font-dir
+                                                doc-dir)))
+                                   (copy-file file
+                                              (string-append dir "/" file))))
+                               (find-files "." ""))))))
+    (native-inputs `(("source" ,source)
+                     ("tar" ,tar)
+                     ("gzip" ,gzip)))
+    (home-page "http://www.gnu.org/software/freefont/")
+    (synopsis "Unicode-encoded outline fonts")
+    (description
+     "The GNU Freefont project aims to provide a set of free outline
+ (PostScript Type0, TrueType, OpenType...) fonts covering the ISO
+10646/Unicode UCS (Universal Character Set).")
+   (license license:gpl3+)))
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 9d1d843a62..5f07401e98 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1,6 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,9 +22,6 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module (guix build-system trivial)
-  #:use-module ((gnu packages base)
-                #:select (tar))
   #:use-module (gnu packages bison)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages flex)
@@ -4440,109 +4436,3 @@ emulation to complete hardware acceleration for modern GPUs.")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
-
-(define-public font-bitstream-vera-ttf
-  (package
-    (name "font-bitstream-vera-ttf")
-    (version "1.10")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnome/sources/ttf-bitstream-vera/"
-                                 version "/ttf-bitstream-vera-"
-                                 version ".tar.bz2"))
-             (sha256
-              (base32
-               "1p3qs51x5327gnk71yq8cvmxc6wgx79sqxfvxcv80cdvgggjfnyv"))))
-    (build-system trivial-build-system)
-    (arguments
-     `(#:modules ((guix build utils))
-       #:builder (begin
-                   (use-modules (guix build utils)
-                                (srfi srfi-26))
-
-                   (let ((tar      (string-append (assoc-ref %build-inputs
-                                                             "tar")
-                                                  "/bin/tar"))
-                         (PATH     (string-append (assoc-ref %build-inputs
-                                                             "bzip2")
-                                                  "/bin"))
-                         (font-dir (string-append %output
-                                                  "/share/fonts/truetype"))
-                         (doc-dir  (string-append %output "/share/doc/"
-                                                  ,name "-" ,version)))
-                     (setenv "PATH" PATH)
-                     (system* tar "xvf" (assoc-ref %build-inputs "source"))
-
-                     (mkdir-p font-dir)
-                     (mkdir-p doc-dir)
-                     (chdir (string-append "ttf-bitstream-vera-" ,version))
-                     (for-each (lambda (ttf)
-                                 (copy-file ttf
-                                            (string-append font-dir "/" ttf)))
-                               (find-files "." "\\.ttf$"))
-                     (for-each (lambda (doc)
-                                 (copy-file doc
-                                            (string-append doc-dir "/" doc)))
-                               (find-files "." "\\.TXT$"))))))
-    (native-inputs `(("source" ,source)
-                     ("tar" ,tar)
-                     ("bzip2" ,bzip2)))
-    (home-page "https://www-old.gnome.org/fonts/")
-    (synopsis "Bitstream Vera sans-serif typeface")
-    (description "Vera is a sans-serif typeface from Bitstream, Inc.  This
-package provides the TrueType (TTF) files.")
-    (license
-     (license:x11-style
-      "https://www-old.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
-
-(define-public freefont-ttf
-  (package
-    (name "freefont")
-    (version "20100919")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnu/freefont/freefont-ttf-"
-                                 version ".tar.gz"))
-             (sha256
-              (base32
-               "1q3h5jp1mbdkinkwxy0lfd0a1q7azlbagraydlzaa2ng82836wg4"))))
-    (build-system trivial-build-system)
-    (arguments
-     `(#:modules ((guix build utils))
-       #:builder (begin
-                   (use-modules (guix build utils)
-                                (srfi srfi-26))
-
-                   (let ((tar      (string-append (assoc-ref %build-inputs
-                                                             "tar")
-                                                  "/bin/tar"))
-                         (PATH     (string-append (assoc-ref %build-inputs
-                                                             "gzip")
-                                                  "/bin"))
-                         (font-dir (string-append %output
-                                                  "/share/fonts/truetype"))
-                         (doc-dir  (string-append %output "/share/doc/"
-                                                  ,name "-" ,version)))
-                     (setenv "PATH" PATH)
-                     (system* tar "xvf" (assoc-ref %build-inputs "source"))
-
-                     (mkdir-p font-dir)
-                     (mkdir-p doc-dir)
-                     (chdir (string-append "freefont-" ,version))
-                     (for-each (lambda (file)
-                                 (let ((dir (if (string-suffix? "ttf" file)
-                                                font-dir
-                                                doc-dir)))
-                                   (copy-file file
-                                              (string-append dir "/" file))))
-                               (find-files "." ""))))))
-    (native-inputs `(("source" ,source)
-                     ("tar" ,tar)
-                     ("gzip" ,gzip)))
-    (home-page "http://www.gnu.org/software/freefont/")
-    (synopsis "Unicode-encoded outline fonts")
-    (description
-     "The GNU Freefont project aims to provide a set of free outline
- (PostScript Type0, TrueType, OpenType...) fonts covering the ISO
-10646/Unicode UCS (Universal Character Set).")
-   (license license:gpl3+)))